Bug 450063 - Signature file encoded in UTF-8 is garbled ...
Signature file encoded in UTF-8 is garbled ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sylpheed (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 21:20 EDT by Jérôme Benoit
Modified: 2013-01-13 07:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 13:58:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my signature file (164 bytes, application/octet-stream)
2008-06-04 21:20 EDT, Jérôme Benoit
no flags Details

  None (edit)
Description Jérôme Benoit 2008-06-04 21:20:49 EDT
Description of problem:

I do not have a real fucking idea what's going on but all my email account on
sylpheed are using a dot file as signature, all of them are in UTF-8 :

.signature:       UTF-8 Unicode text
.signature~:      ISO-8859 text
.signatureperso:  UTF-8 Unicode text
.signatureperso~: ISO-8859 text
.signaturepro:    UTF-8 Unicode text
.signaturepro~:   ISO-8859 tex

and incorporation inside the message garbled all accents (like if they were
treated as ISO-8856-(1|15)), an example : 

 -- 
Jérôme Benoit aka fraggle
La Météo du Net - http://grenouille.com
OpenPGP Key ID : 9FE9161D
Key fingerprint : 9CA4 0249 AF57 A35B 34B3 AC15 FAA0 CB50 9FE9 161D

Convert them to ISO-8859-15 fix the pb but i'm also using mutt with default
locale setting to fr_FR.UTF-8 and it really upset me to change all the locale
setting on mutt because of this bug. 

I've tried the pipe config : iconv -t ISO-8859-15 /home/fraggle/.signature to an
account with zero success (it's even worse). Opening message currently under
edition in gedit, vi or emacs do not show any encoding issue, only when editor
pipe them back in sylpheed, signature is still garbled.  


Version-Release number of selected component (if applicable):

sylpheed-2.5.0-0.1.beta1.i386

How reproducible:

Always.

Steps to Reproduce:
1. Set locale to fr_FR.UTF-8 
2. Use sylpheed with my .signature file.
Comment 1 Jérôme Benoit 2008-06-04 21:20:49 EDT
Created attachment 308407 [details]
my signature file
Comment 2 Fedora Update System 2008-06-05 05:32:07 EDT
sylpheed-2.5.0-0.6.rc has been submitted as an update for Fedora 9
Comment 3 Michael Schwendt 2008-06-05 05:43:22 EDT
> Set locale to fr_FR.UTF-8 

Your locale codeset ends with "utf8" not "UTF-8", which breaks
Sylpheed because it simply looks for "UTF-8". Run "env|grep LANG"
to see.

https://admin.fedoraproject.org/updates/F9/pending/sylpheed-2.5.0-0.6.rc
Comment 4 Jérôme Benoit 2008-06-05 08:19:35 EDT
It do no seem to be the problem ...

[fraggle@fraggle ~]$ cat /etc/sysconfig/i18n 
LANG="fr_FR.UTF-8"
SYSFONT="latarcyrheb-sun16"

[fraggle@fraggle ~]$ env | grep LANG
LANG=fr_FR.utf8[fraggle@fraggle ~]$ env | grep LANG
LANG=fr_FR.utf8

Cheers.
Comment 5 Michael Schwendt 2008-06-05 09:46:32 EDT
> [fraggle@fraggle ~]$ env | grep LANG
> LANG=fr_FR.utf8
            ^^^^^
(!)
Comment 6 Jérôme Benoit 2008-06-05 10:26:33 EDT
Tired ... i'm tired ... :)

What the fuck have happened during init to have locale set to this strange ...
string ?

I must reassign the bug to a another package, like initscripts ... 

Thanks.
Comment 7 Michael Schwendt 2008-06-05 10:37:07 EDT
Both "utf8" and "UTF-8" are equivalent and valid. But Sylpheed
broke, because it evaluates the environment variables directly
instead of using glibc functions.

As why UTF-8 in /etc/sysconfig/i18n ends up as utf8 in GNOME is
another story.

The Sylpheed test update (once it's pushed into the repo)
will accept utf8 as a work-around.
Comment 8 Jérôme Benoit 2008-06-05 15:59:41 EDT
Micheal, 

You're my hero ;-)

If gay weeding was legal and if i was single, you'll be on the top of my list.

Thks, case closed. 
Comment 9 Fedora Update System 2008-06-06 03:51:52 EDT
sylpheed-2.5.0-0.6.rc has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sylpheed'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5047
Comment 10 Fedora Update System 2008-06-08 18:51:32 EDT
sylpheed-2.5.0-0.8.rc2.fc9 has been submitted as an update for Fedora 9
Comment 11 Jérôme Benoit 2008-06-09 16:21:02 EDT
The previous and last sylpheed update close the encoding bug. 

Thks.

Comment 12 Fedora Update System 2008-06-12 22:25:08 EDT
sylpheed-2.5.0-0.8.rc2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-07-26 02:07:26 EDT
sylpheed-2.5.0-0.8.rc2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.