Bug 450067 - RHEL4 U6 storage test traceback on swap label
RHEL4 U6 storage test traceback on swap label
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
ia64 Linux
low Severity low
: ---
: ---
Assigned To: YangKun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 22:04 EDT by Greg Nichols
Modified: 2011-01-24 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 13:13:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2008-06-04 22:04:07 EDT
Description of problem:

The storage test produces a traceback on RHEL4 U6 ia64:

Traceback (most recent call last):
  File "./storage.py", line 456, in ?
    returnValue = test.do(sys.argv)
  File "/usr/share/hts/lib/hts/test.py", line 226, in do
    return self.run()
  File "./storage.py", line 413, in run
    swapLabel=self.getSwapLabel(swapdev)
  File "./storage.py", line 176, in getSwapLabel
    swapString = blkidCommand.getString().split(" ")
  File "/usr/share/hts/lib/hts/command.py", line 108, in getString
    line = self.output[0].strip()
IndexError: list index out of range

Bug found during RHTS test run:
http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=3100145


Version-Release number of selected component (if applicable):

HTS 5.2 R14
Comment 4 Hien Nguyen 2008-07-01 15:18:34 EDT
Does that mean we cannot test HWCert on RHEL4.6 untill RedHat fixes the HTS test
suite ?

Is there any work-around ?
Comment 5 Greg Nichols 2008-07-01 22:06:26 EDT
We've been unable to reproduce this failure.  If you're seeing it, could you
supply the details?
Comment 6 Ben 2008-07-03 14:50:42 EDT
Linking to IT #189826 which contains details of a repro from IBM
Comment 9 YangKun 2008-07-04 07:06:35 EDT
fixed in hts-5.2-19
Comment 10 Hien Nguyen 2008-07-07 14:28:34 EDT
Can I have the patch of storage test fixed to run on HTS-5.2-16 to completed my
HWCert tests ?

-Hien
Comment 11 YangKun 2008-07-08 22:03:24 EDT
Hi Hien,

hts-5.2-19 is not released yet, could you please try following steps as a
work-around for this issue:

  1) remove un-necessary disks from the system, meaning if a disk is not needed
to be tested, just dis-connect it;
  2) if you're using LVM, make sure every volume group has at least one swap
logical volume;
  3) if you're not using LVM, make sure every HD or every RAID volume has at
least one swap partition;
  4) make sure all swap partitions are active(you can see them all in /proc/swaps);
  5) run the command "hts clean" to clear all previous results(please backup
these result files if necessary);
  6) run the command "hts plan" to generate a new plan;
  7) run the command "hts certify --test storage"

Thanks
-YK
Comment 12 Hien Nguyen 2008-07-10 19:44:56 EDT
There are 3 hard disks in the systems I ran the test before: sda contains
RHEL4.6 GA OS and a swap partition; sdb, and sdc didn't have any partitions
created. As suggested in comment#11,

 I created a swap partition in each of sdb
and sdc and made them active and show up in /proc/swaps. Then the storage test
passed on three disks.

Can I use this work around results to submit for the HWCert ?

-Hien
Comment 13 YangKun 2008-07-10 22:52:55 EDT
Hi Hien,

Yes, these work around results can be used for HwCert.

-YK
Comment 15 Greg Nichols 2008-08-27 21:35:47 EDT
Fix will not be in HTS 5.2 R19.   It's currently in HTS 5.3 R1.

Note You need to log in before you can comment on or make changes to this bug.