Bug 450081 - Can't connect bluetooth mouse (MS Wireless Notebook Presenter Mouse 8000)
Can't connect bluetooth mouse (MS Wireless Notebook Presenter Mouse 8000)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez-gnome (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 03:55 EDT by Miroslav Pragl
Modified: 2009-05-10 18:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 13:53:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is dump from hcitool name 00:12:5A:67:A3:C1 >name.txt (50 bytes, text/plain)
2008-06-26 08:55 EDT, Miroslav Pragl
no flags Details

  None (edit)
Description Miroslav Pragl 2008-06-05 03:55:38 EDT
Description of problem:
Can't connect bluetooth mouse (MS Wireless Notebook Presenter Mouse 8000)

Version-Release number of selected component (if applicable):
bluez-gnome-0.26-1.fc9.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Gnome Bluez - Preferences - services - Input service - Add
2. Choose my mouse (it's name is shortened to Microsoft - maybe the "(R)" char
in device name makes problems?) - Connect
3.Bluez Window simply DISAPPEARS (no error message). Just following one in
/var/log/messages:
Jun  5 09:50:08 mirek-nb hcid[2286]: Hangup or error on HIDP control socket

  
Actual results:
Mouse not connected

Expected results:
Mouse should connect and do its job :)

Additional info:
I used the mouse before with FC8/i386 on the same machine (it's core 2 duo
notebook hp/cpq 6710b) - worked just as expected. Guys, I always liked fedora
but FC9 seems to be far worst release - too many changes which are visible
because something what worked just doesn't work now, not because of these added
features that just few people enjoy :(

I hope I can help you improve it

MP
Comment 1 Miroslav Pragl 2008-06-26 08:52:15 EDT
Hi,
I yum-updated bluez stuff today:

Jun 26 14:25:55 mirek-nb yum: Updated: bluez-utils-alsa-3.32-1.fc9.x86_64
Jun 26 14:25:57 mirek-nb yum: Updated: bluez-utils-3.32-1.fc9.x86_64
Jun 26 14:25:57 mirek-nb yum: Updated: bluez-utils-cups-3.32-1.fc9.x86_64

and the problem is 99% SOLVED. The -1% is fact that I can use the mouse but it's
name is truncated to "Microsoft" from "Microsoft (tm) Wireless ... mouse". Seems
that "TM" character is bad guy. Is there a way how to dump the name "as is"?

hcitool scan finds "00:12:5A:67:A3:C1	Microsoft"
hcitool name 00:12:5A:67:A3:C1 finds "Microsoft� Wireless Notebook Presenter
Mouse 8000" - see attached txt file

MP
Comment 2 Miroslav Pragl 2008-06-26 08:55:11 EDT
Created attachment 310326 [details]
this is dump from hcitool name 00:12:5A:67:A3:C1 >name.txt  

the name  actually contains (R) sign (0xAE) - Microsoft(R) Wireless Notebook
Presenter Mouse 8000

MP
Comment 3 Bastien Nocera 2008-10-14 16:08:26 EDT
It's most likely the string being in the wrong encoding, or hcid not setting its default encoding to UTF-8 (if it is actually UTF-8).

The name of the mouse not being the right one in F9 isn't something I would really spend time on, but let us know whether the naming problem still exists with F10 when you get to installing it. We could more easily work towards fixing the problem with the latest versions.
Comment 4 Bastien Nocera 2009-03-05 13:53:07 EST
Note that the mouse is broken, as the device name is supposed to be in UTF-8. So MS are breaking the spec. Even then, I've implemented a work-around, and posted the patch at:
http://thread.gmane.org/gmane.linux.bluez.kernel/1687

Work-around is in bluez-4.32-4 in rawhide.
Comment 5 Brian Morrison 2009-05-09 16:36:08 EDT
Is there any chance of getting updated packages for bluez released for Fedora 10 please? I have an MS mouse of the same type and it worked in Fedora 8 I think, but no longer now. Something equal to or later than 4.32-4 would be really useful.

Tried a local package rebuild but even after adding --enable-alsa to the configure step the alsa .so files still don't get built.

Thanks!
Comment 6 Bastien Nocera 2009-05-09 19:52:31 EDT
(In reply to comment #5)
> Is there any chance of getting updated packages for bluez released for Fedora
> 10 please? I have an MS mouse of the same type and it worked in Fedora 8 I
> think, but no longer now. Something equal to or later than 4.32-4 would be
> really useful.

You probably need to update your system, Miroslav's mouse works fine, the only fix was for the mouse name, which really isn't something I'm going to spend time on for F10.
Comment 7 Brian Morrison 2009-05-09 20:14:45 EDT
My F10 system is fully updated, so when you say update, what did you have in mind?

I can pair the mouse with the laptop, but it has done nothing after that, so I was wondering if it could be down to udev etc not recognising it as a mouse and failing to set things up correctly.

I suppose F11 will be out soon, so I'll upgrade then but I would like to understand what's gone wrong since F8.
Comment 8 Bastien Nocera 2009-05-10 18:17:07 EDT
File a separate bug with the debug output of bluetoothd. This bug is closed, and there's no point in adding more comments to it.

Note You need to log in before you can comment on or make changes to this bug.