Bug 450083 - DRIConf in need of TLC, spelling lessons
DRIConf in need of TLC, spelling lessons
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: driconf (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 04:15 EDT by Vince Schiavoni
Modified: 2008-06-26 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: driconf-0.9.1-8.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 11:38:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to transform glxinfo information to unicode (1.09 KB, patch)
2008-06-05 13:02 EDT, Toshio Ernie Kuratomi
no flags Details | Diff
Patch to update deprecated toolbar methods (5.34 KB, patch)
2008-06-05 20:12 EDT, Toshio Ernie Kuratomi
no flags Details | Diff

  None (edit)
Description Vince Schiavoni 2008-06-05 04:15:25 EDT
Description of problem:
DRIConf code is becoming more and more stale. Needs some TLC, and maybe some 
help with parsing:
[...]
[vince@localhost Thu Jun 05 03:47:13 ~]$ driconf
/usr/lib/python2.5/site-packages/driconf_simpleui.py:461: GtkWarning: Failed to 
set text from markup due to error parsing markup: Error on line 1 char 100: 
Invalid UTF-8 encoded text - not valid '<b>Mesa DRI Mach64 [Rage Pro] 20051019 
AGP 2x x86/MMX/SSE (Gareth Hughes, Leif Delgass,Jos� Fonseca)</b>'
  deviceLabel.set_markup("<b>" + commonui.escapeMarkup(text) + "</b>")
/usr/lib/python2.5/site-packages/driconf_simpleui.py:522: GtkWarning: Failed to 
set text from markup due to error parsing markup: Error on line 1 char 100: 
Invalid UTF-8 encoded text - not valid '<b>Mesa DRI Mach64 [Rage Pro] 20051019 
AGP 2x x86/MMX/SSE (Gareth Hughes, Leif Delgass,Jos� Fonseca)</b>'
  self.add(self.vbox)
/usr/lib/python2.5/site-packages/driconf_complexui.py:843: DeprecationWarning:
  "priv", self.configTree.saveConfig, None, -1)
/usr/lib/python2.5/site-packages/driconf_complexui.py:846: DeprecationWarning:
  "priv", self.configTree.reloadConfig, None, -1)
/usr/lib/python2.5/site-packages/driconf_complexui.py:847: DeprecationWarning:
  self.toolbar.append_space()
/usr/lib/python2.5/site-packages/driconf_complexui.py:850: DeprecationWarning:
  "priv", self.configTree.newItem, None, -1)
/usr/lib/python2.5/site-packages/driconf_complexui.py:853: DeprecationWarning:
  "priv", self.configTree.removeItem, None, -1)
/usr/lib/python2.5/site-packages/driconf_complexui.py:856: DeprecationWarning:
  "priv", self.configTree.moveUp, None, -1)
/usr/lib/python2.5/site-packages/driconf_complexui.py:859: DeprecationWarning:
  "priv", self.configTree.moveDown, None, -1)
/usr/lib/python2.5/site-packages/driconf_complexui.py:862: DeprecationWarning:
  "priv", self.configTree.properties, None, -1)
/usr/lib/python2.5/site-packages/driconf_complexui.py:863: DeprecationWarning:
  self.toolbar.append_space()
/usr/lib/python2.5/site-packages/driconf_complexui.py:872: DeprecationWarning:
  self.aboutHandler, None, -1)
/usr/lib/python2.5/site-packages/driconf_complexui.py:873: DeprecationWarning:
  self.toolbar.append_space()
/usr/lib/python2.5/site-packages/driconf_complexui.py:876: DeprecationWarning:
  self.exitHandler, None, -1)
[Vince@localhost Thu Jun 05 04:02:05 ~]$
[...]

Version-Release number of selected component (if applicable):
driconf-0.9.1-7.fc9.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 9
2. Install driconf
3. Open driconf from terminal
4. Observe meltdown
  
Actual results:
Numerous python/parsing warnings as noted above.

Expected results:
Absolutely error-free execution; Direct Rendering a bonus.

Additional info:
An otherwise outstanding little utility, no other options/substitutes 
available, please don't let this one die.
Comment 1 Kevin Fenzi 2008-06-05 11:58:44 EDT
This looks like a UTF8 bug with driconf due to that video driver authors name. ;( 

I will see if I can work up a fix or find someone who can do so... 
Comment 2 Toshio Ernie Kuratomi 2008-06-05 13:02:28 EDT
Created attachment 308461 [details]
patch to transform glxinfo information to unicode
Comment 3 Toshio Ernie Kuratomi 2008-06-05 13:05:36 EDT
Are you able to test the above patch?  I don't have the problem so I worked a
bit blind on this.  This is not a great solution as there's likely to be other
places in the code with the same sorts of issues.  And it would be nice if this
was solved further up the stack rather than in driconf code.  But if it works it
might be a workaround and upstream can look at it to see what they're going to
have to do everywhere.
Comment 4 Vince Schiavoni 2008-06-05 17:13:58 EDT
Thanx for the quick response! And the patch....

Patch applied successfully: works perfectly for simple UI, no CLI output 
whatsoever as long as in "Simple UI" mode, but still get same "error" messages 
as above when switching GUI to "Expert Mode" (everything starting with: "/usr/
lib/python2.5/site-packages/driconf_complexui.py:" and down). Patch for 
driconf_complexui.py? :D

I assume this simpleui.py patch will work for F8 as well? - will test shortly.

BTW, these "error" messages do not appear to affect driconf functionality, but 
since I don't know too much about the inner workings of this stuff, I didn't 
know what they really meant....

Many Thanx and Regards,
VJS
Comment 5 Vince Schiavoni 2008-06-05 17:49:05 EDT
Thanx for the quick response! And the patch....

Patch applied successfully: works perfectly for simple UI, no CLI output 
whatsoever as long as in "Simple UI" mode, but still get same "error" messages 
as above when switching GUI to "Expert Mode" (everything starting with: "/usr/
lib/python2.5/site-packages/driconf_complexui.py:" and down). Patch for 
driconf_complexui.py? :D

I assume this simpleui.py patch will work for F8 as well? - will test shortly.

BTW, these "error" messages do not appear to affect driconf functionality, but 
since I don't know too much about the inner workings of this stuff, I didn't 
know what they really meant....

Many Thanx and Regards,
VJS
Comment 6 Vince Schiavoni 2008-06-05 17:57:38 EDT
OOPS! Sorry about that - all I did was hit "Refresh"....

Yes, the patch works on F8 too, exact same results.

BTW, glxinfo has the same "stutter" when trying to parse/read that letter: é

Thanx Again, sorry about the "spam",
VJS
Comment 7 Toshio Ernie Kuratomi 2008-06-05 20:12:40 EDT
Created attachment 308501 [details]
Patch to update deprecated toolbar methods

Okay, here's a patch to update the deprecated toolbar methods with the newer
methods from pygtk.  I'm not sure if upstream will want this verbatim or if
they'll want to conditionalize to work with older pygtk versions but this is
what they'll want to implement for the newer versions.
Comment 8 Toshio Ernie Kuratomi 2008-06-05 20:17:46 EDT
Re: glxinfo... you can file a bug against glx-utils if you'd like.  I'm
primarily a python programmer these days and glxinfo is written in C so it's not
something I can knock off in an hour.
Comment 9 Vince Schiavoni 2008-06-05 22:37:30 EDT
Yes, this second patch worked perfectly. All fixed. :D

Thank You Mr. Kuratomi for your time and help on this - by far the fastest
response I've ever gotten. I'll feel much more confident recommending driconf to
other users who want/need to change their xorg.conf DRI settings.

Many Thanx and Best Regards,
VJS
Comment 10 Fedora Update System 2008-06-08 18:43:00 EDT
driconf-0.9.1-8.fc9 has been submitted as an update for Fedora 9
Comment 11 Fedora Update System 2008-06-08 19:43:54 EDT
driconf-0.9.1-7.fc8 has been submitted as an update for Fedora 8
Comment 12 Fedora Update System 2008-06-08 19:51:55 EDT
driconf-0.9.1-7.fc7 has been submitted as an update for Fedora 7
Comment 13 Kevin Fenzi 2008-06-08 19:53:11 EDT
Thanks for all the great patches Toshio!

I have pushed out the patched package to updates-testing... 
I'll also notify upstream. 

Thanks for the bug report!
Comment 14 Fedora Update System 2008-06-09 23:12:17 EDT
driconf-0.9.1-7.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update driconf'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-5100
Comment 15 Vince Schiavoni 2008-06-11 02:08:42 EDT
(In reply to comment #11)
> driconf-0.9.1-7.fc8 has been submitted as an update for Fedora 8

Installed from updates-testing repo. Works for me.

Thanx and Regards,
VJS
Comment 16 Kevin Fenzi 2008-06-11 12:27:55 EDT
Excellent. I am going to go ahead and push these to stable as F7 is close to the
end of it's life. 

Thanks again for the bug report!
Comment 17 Vince Schiavoni 2008-06-12 12:48:38 EDT
(In reply to comment #10)
> driconf-0.9.1-8.fc9 has been submitted as an update for Fedora 9

Installed from updates-testing repo. Works for me.

Thanx and Regards,
VJS
Comment 18 Fedora Update System 2008-06-12 22:19:26 EDT
driconf-0.9.1-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2008-06-12 22:23:08 EDT
driconf-0.9.1-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2008-06-12 22:26:26 EDT
driconf-0.9.1-7.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Kevin Fenzi 2008-06-26 11:38:32 EDT
I'm going to go ahead and close this now.

Feel free to re-open or file a new bug if you spot further issues. 


Note You need to log in before you can comment on or make changes to this bug.