Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 450087 - libssl.so.6 missing
Summary: libssl.so.6 missing
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: deluge
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-05 09:25 UTC by Martin Ellison
Modified: 2008-06-05 16:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-05 16:51:49 UTC
Type: ---


Attachments (Terms of Use)

Description Martin Ellison 2008-06-05 09:25:44 UTC
Description of problem:
 libssl.so.6: cannot open shared object file: No such file or directory
I receive this message when trying to run various applications eg deluge.

Version-Release number of selected component (if applicable):
libssl.so.6

How reproducible:
Consistent

Steps to Reproduce:
1. run deluge
  
Actual results:
Program does not run, gives message "libssl.so.6: cannot open shared object
file: No such file or directory"


Expected results:
Program runs


Additional info:
yum update deluge is failing with a missing dependency error on the same file.

Comment 1 Ignacio Vazquez-Abrams 2008-06-05 09:33:05 UTC
Any particular version and arch of deluge and openssl packages that this is
happening with?

Comment 2 Martin Ellison 2008-06-05 09:38:38 UTC
[root@localhost ~]# rpm -q deluge
deluge-0.5.8.6-1.fc8.x86_64
[root@localhost ~]# rpm -q openssl
openssl-0.9.8g-6.fc9.x86_64
openssl-0.9.8g-6.fc9.i686
It should be a standard F8->F9->yum upgrade version for everything (except I
have to exclude deluge etc because of the yum dependency error).

Also, now I am getting Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libcrypto.so.7 is needed by (installed) openldap-2.4.8-3.fc9.i386....
libssl.so.7 is needed by (installed) openldap-2.4.8-3.fc9.i386.....


Comment 3 Martin Ellison 2008-06-05 09:41:14 UTC
Also,
[root@localhost ~]# ls -l /usr/lib64/libssl.so
lrwxrwxrwx 1 root root 28 2008-05-30 01:14 /usr/lib64/libssl.so ->
../../lib64/libssl.so.0.9.8g
[root@localhost ~]# ls -l /usr/lib/libssl.so
ls: cannot access /usr/lib/libssl.so: No such file or directory


Comment 4 Tomas Mraz 2008-06-05 09:46:28 UTC
Yes it is missing because there is no libssl.so.6 in Fedora 9. There is
libssl.so.7. And deluge should link against the new version of the library.


Comment 5 Martin Ellison 2008-06-05 10:10:50 UTC
See also bug 450089 for stunnel, apparently the same fault.

Comment 6 Peter Gordon 2008-06-05 16:08:57 UTC
You're using the F8 deluge with F9's openssl, but F8's deluge is linked against
libssl.so.6 (which is the most recent available to F8), but F9's openssl does
not contain this library. Please upgrade to the latest F9 deluge
(http://koji.fedoraproject.org/koji/buildinfo?buildID=50313 before it hits the
repo) and this error should disappear.


Comment 7 Martin Ellison 2008-06-05 16:45:41 UTC
OK, done that; it's working now thanks.

Comment 8 Peter Gordon 2008-06-05 16:51:49 UTC
Glad to hear that. I'll close this bug, then...


Note You need to log in before you can comment on or make changes to this bug.