Bug 450119 - System-config-printer freezes on samba printer installation
System-config-printer freezes on samba printer installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 10:14 EDT by antonio montagnani
Modified: 2008-06-10 05:51 EDT (History)
0 users

See Also:
Fixed In Version: 1.0.2-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 05:51:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Troubleshooting file (45.52 KB, text/plain)
2008-06-09 03:18 EDT, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2008-06-05 10:14:20 EDT
Description of problem:
When I try to install a printer connected to a Window computer, printer doesn't
show up and freezes

Version-Release number of selected component (if applicable):
system-config-printer-1.0.0-2.fc10.i386

How reproducible:
alaways

Steps to Reproduce:
1.open system-config-printer
2.click on New
3.click on Windows printer via Samba
  
Actual results:
network printer doesn't show up and  s-c-p freezes

Expected results:
it should install printer

Additional info:
Comment 1 Tim Waugh 2008-06-05 10:48:15 EDT
I haven't been able to reproduce this here, but I've added some debugging so
that I should be able to pin-point the problem.

Please fetch system-config-printer-1.0.0-3.fc10 from koji (or wait for rawhide
to get it) and then run:

system-config-printer --debug

from a terminal window.  Try to reproduce the problem, and you should see some
debug messages in the output.  Paste them here.  Thanks.
Comment 2 antonio montagnani 2008-06-09 03:18:54 EDT
Created attachment 308669 [details]
Troubleshooting file
Comment 3 Tim Waugh 2008-06-09 03:31:04 EDT
Thanks.  Actually that isn't quite what I was after, but does show that samba is
not behaving correctly in rawhide.  That is sort of expected: Fedora 9 showed
the same bug when printing through samba, and it has been fixed by a newer
package.  Looks like that package just hasn't been built for rawhide yet.

I'm more interested in your report that the system-config-printer application
freezes while browsing for a Windows print share.  Please run
'system-config-printer --debug' from a terminal and try to reproduce the
problem.  When you manage to get system-config-printer to freeze again, please
paste the output from the terminal window into this bug report.  Thanks.
Comment 4 antonio montagnani 2008-06-09 03:41:35 EDT
Tim,

I deleted the printer and re-installed it: It worked (slowly) and when it called
for the choice of printer driver it took a long time to answer: I got these
messages in terminal window at that particular point.


Trying make/model names
Trying best match
postscript <= Printer <= Raw Queue
postscript: match length 1
Searching for model ID 'printer', 'printe%dprinter' % 0
Text-only fallback
[u'textonly.ppd']
No ID match for device smb://WORKGROUP/CELERON/HPLaserJ:
  <manufacturer>Generic</manufacturer>
  <model>Printer</model>
  <description>Generic Printer</description>
  <commandset></commandset>
Using textonly.ppd
Will fetch ppd? 0
get_notifications
update
Comment 5 antonio montagnani 2008-06-09 03:52:30 EDT
I tried to install a second Windows printer and now it freezes when the Browser
SMB should show printer list

system-config-printer --debug
Connected as user antonio
refresh
Created subscription 17
<monitor.Monitor instance at 0x9691b6c>: printers and jobs lists provided
update
Authentication pass: 1
Authentication: password callback set
Authentication pass: 1
Authentication: password callback set
Authentication pass: 1
Authentication: password callback set
Got password callback
Authentication pass: 2
Authentication: Try as root
Connected as user root
Got password callback
Authentication pass: 3
get_notifications
update
Authentication: Reconnect
Connected as user root
Got password callback
Authentication pass: 1
Authentication: password callback set
fetchDevices
Lock acquired for devices thread
Devices thread started
Connecting (devices)
Fetching devices
Closing connection (devices)
Releasing devices lock
Got devices
socket: scheme is None
queryPPDs
Lock acquired for PPDs thread
PPDs thread started
Connecting (PPDs)
Fetching PPDs
pysmb: got password callback
Comment 6 Tim Waugh 2008-06-10 05:51:29 EDT
Thanks.  Should be fixed in 1.0.2.

Note You need to log in before you can comment on or make changes to this bug.