Bug 450131 - Can't run system-config-network-cmd in kickstart
Can't run system-config-network-cmd in kickstart
Status: CLOSED DUPLICATE of bug 451756
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 10:42 EDT by Chris Adams
Modified: 2008-11-28 10:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-28 10:30:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2008-06-05 10:42:08 EDT
I have kickstart files that run system-config-network-cmd in %post to configured
the installed networking.  That no longer works with Fedora 9, because s-c-n-cmd
apparently tries to talk to hal via dbus.  I can start the messagebus service in
the kickstart %post, but since hal is already running (in the anaconda root), I
can't start it in the chroot %post for the kickstart script to use.

Is there any way around this?  What is the recommended way to configure static
network interfaces in a kickstart?
Comment 1 Jiri Moskovcak 2008-11-28 10:30:26 EST

*** This bug has been marked as a duplicate of bug 451756 ***

Note You need to log in before you can comment on or make changes to this bug.