Bug 450180 - rt73usb drivers crashes on suspend
rt73usb drivers crashes on suspend
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 14:33 EDT by Bastien Nocera
Modified: 2008-12-11 13:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 13:49:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suspend crash log (6.15 KB, text/plain)
2008-06-05 14:33 EDT, Bastien Nocera
no flags Details

  None (edit)
Description Bastien Nocera 2008-06-05 14:33:07 EDT
I guess this is the problem:
* Tue May 27 2008 John W. Linville <linville@redhat.com> 2.6.25.4-34
- Upstream wireless updates from 2008-05-22
  (http://marc.info/?l=linux-wireless&m=121146112404515&w=2)

Running 2.6.25.4-30.fc9.x86_64 works fine, kernel-2.6.25.4-42.fc9.x86_64 crashes
with the following trace:
Jun  5 17:39:08 cookie kernel:  [autoremove_wake_function+0/56] ?
autoremove_wake_function+0x0/0x38
Jun  5 17:39:08 cookie kernel:  [_end+114129375/2114620868]
:rt2x00usb:rt2x00usb_disable_radio+0x82/0x9c
Jun  5 17:39:08 cookie kernel:  [_end+114350655/2114620868]
:rt73usb:rt73usb_set_device_state+0xda7/0xed0
Jun  5 17:39:08 cookie kernel:  [_end+113980992/2114620868]
:rt2x00lib:rt2x00lib_disable_radio+0x70/0x88
Jun  5 17:39:08 cookie kernel:  [_end+113982099/2114620868]
:rt2x00lib:rt2x00lib_stop+0x1a/0x4b
Jun  5 17:39:08 cookie kernel:  [_end+113984089/2114620868]
:rt2x00lib:rt2x00mac_stop+0x16/0x18
Jun  5 17:39:08 cookie kernel:  [_end+113644808/2114620868]
:mac80211:ieee80211_stop+0x369/0x3b6

Device is:
Bus 001 Device 003: ID 050d:705a Belkin Components F5D7050A Wireless Adapter
using the rt73usb.
Comment 1 Bastien Nocera 2008-06-05 14:33:07 EDT
Created attachment 308473 [details]
Suspend crash log
Comment 2 John W. Linville 2008-06-05 14:41:49 EDT
Please try -39:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=50951
Comment 3 Bastien Nocera 2008-06-11 06:03:29 EDT
-39 crashes with the same trace.
Comment 4 Nikos Charonitakis 2008-06-29 04:36:42 EDT
also crashes all system on shutdown (2.6.25.6-55.fc9.i686)

Comment 5 John W. Linville 2008-10-29 11:16:24 EDT
Does this issue remain with current kernels?
Comment 6 John W. Linville 2008-12-11 13:49:27 EST
Closed due to lack of response...please reopen if the problem remains with
current kernels.

Note You need to log in before you can comment on or make changes to this bug.