Bug 450186 - deprecate malloc_hook(3) man page
deprecate malloc_hook(3) man page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ivana Varekova
:
: 485503 (view as bug list)
Depends On:
Blocks: 499522
  Show dependency treegraph
 
Reported: 2008-06-05 15:03 EDT by Jeff Bastian
Modified: 2013-04-12 16:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0587
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 09:38:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2008-06-05 15:03:52 EDT
+++ This bug was initially created as a clone of Bug #450182 +++

Cloned for RHEL5 tracking.

-------- Original Message --------
Subject: Re: Alternatives to Malloc Hooks and RHEL?
Date: Tue, 20 May 2008 10:20:06 -0700
From: Ulrich Drepper <drepper@redhat.com>

Johnray Fuller wrote:
> According to this post:
> 
> http://sources.redhat.com/ml/libc-alpha/2006-07/msg00108.html
> 
> One should not use malloc hooks as they are deprecated.

Indeed, the will actually stop working completely in the not so distant
future.  They also don't really work for multi-threaded code anymore.


-- Additional comment from jbastian@redhat.com on 2008-06-05 15:01 EST --
As indicated above, malloc hooks are broken and going away, but the
malloc_hook(3) man page does not reflect this.  Can it be updated to indicate
it's deprecated?
Comment 7 errata-xmlrpc 2008-07-16 09:38:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0587.html
Comment 8 James M. Leddy 2009-10-16 10:22:31 EDT
*** Bug 485503 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.