Bug 450200 - xguest behaves very strangely with user switching
xguest behaves very strangely with user switching
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 17:01 EDT by Bill Nottingham
Modified: 2014-03-16 23:14 EDT (History)
4 users (show)

See Also:
Fixed In Version: pam-1.0.1-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 06:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-06-05 17:01:44 EDT
Description of problem:

xguest doesn't really work with user switching the way I'd expect.

If you switch away from xguest, you get the normal GDM dialog.
'Guest' is marked as 'currently logged in'

OK, I suppose that makes some sense. But, ideally, it would allow you to create
a second guest login. 

In any case, click on it. It asks for a password. But xguest doesn't *have* a
password, so obviously you can't enter a working one to go back to xguest's
session. If you ctrl-alt-backspace out of this greeter (or ctrl-alt-f<whatever>
back to the original session), xguest's screen is locked with the same password.
Oops.

Version-Release number of selected component (if applicable):

xguest-1.0.6-7.fc9.noarch
gdm-user-switch-applet-2.22.0-5.fc9.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Log in as xguest
2. Play around with user switching
Comment 1 Daniel Walsh 2008-06-09 15:58:26 EDT
There was a bug in pam_selinux_permit that would not allow you to login if the
uid was currently logged in.  The problem was for gnome-screensaver this did not
make sense.  So I though tomas changed it to only check if the app that is doing
the checking is running as root.

Comment 2 Tomas Mraz 2008-10-01 06:09:17 EDT
Yes, this was already fixed some time ago.

Note You need to log in before you can comment on or make changes to this bug.