Bug 450208 - NFS doesn't stop rpc.rquotad
NFS doesn't stop rpc.rquotad
Status: CLOSED DUPLICATE of bug 470483
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.2
i386 Linux
low Severity low
: rc
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 17:24 EDT by Rob Marti
Modified: 2009-03-17 10:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 13:35:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for /etc/init.d/nfs - fixes handling of rquota daemon (627 bytes, patch)
2008-07-15 10:48 EDT, Msquared
no flags Details | Diff

  None (edit)
Description Rob Marti 2008-06-05 17:24:31 EDT
Description of problem:
service nfsd stop does not stop rpc.quotad by default

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1.  service nfs start
2.  service nfs stop
3.  ps aux | grep quotad to see that rpc.quotad is still running.
  
Actual results:
[root@lnxdocimaging ~]# service nfs start
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
[root@lnxdocimaging ~]# service nfs stop
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
[root@lnxdocimaging ~]# service nfs start
Starting NFS services:                                     [  OK  ]
Starting NFS quotas: rpc.rquotad: Cannot bind to given address: Address already
in use
                                                           [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
[root@lnxdocimaging ~]# ps aux | grep quotad
root      9142  0.0  0.0   3884   232 ?        Ss   12:16   0:00 rpc.rquotad -p 875
root      9392  0.0  0.0   3888   252 ?        Ss   12:16   0:00 rpc.rquotad -p 875
root      9555  0.0  0.0   3912   672 pts/0    S+   12:16   0:00 grep quotad


Expected results:
[root@lnxdocimaging ~]# service nfs start
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
[root@lnxdocimaging ~]# service nfs stop
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
[root@lnxdocimaging ~]# service nfs start
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
[root@lnxdocimaging ~]# ps aux | grep quotad
root      9392  0.0  0.0   3888   252 ?        Ss   12:16   0:00 rpc.rquotad -p 875
root      9555  0.0  0.0   3912   672 pts/0    S+   12:16   0:00 grep quotad

Additional info:
All I had to do was uncomment the following line in /etc/sysconfig/nfs:
RQUOTAD="/usr/sbin/rpc.rquotad"

The problem stems from the fact that $RQUOTAD is initialized in the start
portion of /etc/init.d/nfs but not the stop portion.
Comment 1 Msquared 2008-07-15 10:46:39 EDT
$RQUOTAD is also not initialised in the status portion of the init script. 
Patch on its way...
Comment 2 Msquared 2008-07-15 10:48:44 EDT
Created attachment 311841 [details]
Patch for /etc/init.d/nfs - fixes handling of rquota daemon

Update nfs-utils to 1.0.9-33.el5, then apply this patch.  rquota will now be
reported by service nfs status, and will be stopped by service nfs stop.
Comment 3 Jonathan Peatfield 2008-11-24 16:20:27 EST
While this is a trivial problem, it would be nice if this could be rolled into the next nfs-utils release - since it is *such* a trivial change...

Of course the next 'rc' release is probably due soon.

 -- Jon
Comment 4 Dr. Tilmann Bubeck 2008-11-27 05:07:56 EST
This bug also appears in the newest Fedora 10: nfs-utils-1.1.4-1.fc10.i386
Comment 5 Steve Dickson 2008-12-01 13:35:27 EST

*** This bug has been marked as a duplicate of bug 470483 ***
Comment 6 Jonathan Peatfield 2008-12-01 14:52:21 EST
Hmm #470483 isn't visible (to me anyway).  Is it standard policy to close, referring to a non-public bugzilla entry?

Or is #470483 a different *kind* of entry?

Note You need to log in before you can comment on or make changes to this bug.