This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450231 - g++: Internal error: Segmentation fault (program cc1plus)
g++: Internal error: Segmentation fault (program cc1plus)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 440934
  Show dependency treegraph
 
Reported: 2008-06-05 21:01 EDT by Tom "spot" Callaway
Modified: 2008-06-24 15:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 15:08:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2008-06-05 21:01:36 EDT
Description of problem:

QuantLib (one of my Fedora packages) no longer compiles cleanly in Fedora 9 or
Rawhide. Specifically, it repeatably fails here:

[spot@localhost test-suite]$ make
if g++ -DHAVE_CONFIG_H -I. -I. -I../ql  -I.. -I.. -DQL_WORKING_BOOST_STREAMS -O2
-g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -fpermissive  -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic -MT riskstats.o -MD -MP -MF ".deps/riskstats.Tpo" -c -o
riskstats.o riskstats.cpp; \
	then mv -f ".deps/riskstats.Tpo" ".deps/riskstats.Po"; else rm -f
".deps/riskstats.Tpo"; exit 1; fi
{standard input}: Assembler messages:
{standard input}:34250: Warning: end of file not at end of a line; newline inserted
{standard input}:34355: Error: undefined symbol `.LLSDATT3942' in operation
{standard input}:34358: Error: undefined symbol `.LLSDACSE3942' in operation
g++: Internal error: Segmentation fault (program cc1plus)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
make: *** [riskstats.o] Error 1

Unfortunately, distilling this down to a test case isn't going to be easy. Your
best bet would be to checkout the QuantLib module from Fedora CVS, then try to
build it on x86_64 with either Fedora 9 or rawhide.
Comment 1 Jakub Jelinek 2008-06-23 06:44:04 EDT
Can you still reproduce this with gcc-4.3.1-2?  I can't.
Comment 2 Tom "spot" Callaway 2008-06-24 15:08:42 EDT
Nope. Looks like this one is fixed. Thanks.

Note You need to log in before you can comment on or make changes to this bug.