Bug 450233 - Firestarter fails to start on boot using networkmanager
Firestarter fails to start on boot using networkmanager
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firestarter (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Miller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 21:19 EDT by David
Modified: 2009-11-09 12:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-09 12:37:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David 2008-06-05 21:19:41 EDT
Description of problem:
With networkmanager set to on in chkconfig you get a error on boot with firestarter saying failed. If 
you open firestarter on desktop it works fine.
However if you disable networkmanager to off in chkconfig and set network to on in chkconfig no 
more errors on boot and firestarter runs without having to open it on the desktop.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mark Whidby 2008-08-21 07:37:40 EDT
I find it will work if I install a NetworkManager dispatcher script.
See:- 

http://www.darrenalbers.net/wiki/index.php?title=NetworkManagerScripts

I then chkconfig firestarter off and let the script start handle it.
Comment 2 Jessica Sterling 2009-03-06 17:06:59 EST
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Paul Jenner 2009-04-17 14:59:49 EDT
This is a Firestarter bug, not NetworkManager. It should be changed to the Firestarter component.
Comment 4 Dan Williams 2009-10-16 18:38:01 EDT
Yeah; if firestarter can't handle network devices coming and going, or even not available when it starts, we have a few options:

1) install the dispatcher script to restart firestarter when the network config changes.  This is the sledgehammer approach
2) fix firestarter to respond to network events (either netlink or dbus) and handle the fact that networking is dynamic and can change on-the-fly
3) set NETWORKWAIT=yes in /etc/sysconfig/network which will make NM block startup until something has a network connection, or until 30 seconds have passed.
Comment 5 Adam Miller 2009-11-09 12:37:13 EST
Firestarter has been retired as a package since upstream has been dead for years.

Note You need to log in before you can comment on or make changes to this bug.