Bug 450249 - some keyboard parts and mouse freeze from time to time
some keyboard parts and mouse freeze from time to time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-keyboard (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 04:22 EDT by Matěj Cepl
Modified: 2008-10-19 18:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-19 18:43:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (104.99 KB, text/plain)
2008-06-06 04:27 EDT, Matěj Cepl
no flags Details
/etc/X11/xorg.conf (914 bytes, text/plain)
2008-06-06 04:27 EDT, Matěj Cepl
no flags Details
output of dmesg (118.64 KB, text/plain)
2008-06-06 04:32 EDT, Matěj Cepl
no flags Details
/var/log/messages (196.89 KB, application/x-bzip2)
2008-06-06 04:44 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2008-06-06 04:22:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
From time to time without any particular pattern of action either keyboard starts to behave like if some modification key was constantly pressed (most often Ctrl) or touchpad stops producing any clicks (I can move it around, but even pressing the particular button on the touchpad doesn't generate click in buttons).

Don't know much what to do about it, so just shooting information in the dark. The computer is a notebook HP Compaq 6710s, with xorg.conf and Xorg.0.log attached. This is output of setxkbmap -print

[matej@viklef redhat]$ setxkbmap -print
xkb_keymap {
	xkb_keycodes  { include "xfree86+aliases(qwertz)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete+ledscroll(group_lock)"	};
	xkb_symbols   { include "pc+cz(qwerty)+inet(pc105)+us:2+altwin(super_win)+group(shifts_toggle)+level3(ralt_switch_multikey)+ctrl(nocaps)+compose(rctrl)+eurosign(e)+nbsp(none)"	};
	xkb_geometry  { include "pc(pc105)"	};
};
[matej@viklef redhat]$ 


Version-Release number of selected component (if applicable):
xorg-x11-drv-keyboard-1.3.0-3.fc9.i386 xorg-x11-drv-mouse-1.3.0-2.fc9.i386

How reproducible:
Sometimes


Steps to Reproduce:
1.see above
2.
3.

Actual Results:
see above

Expected Results:


Additional info:
Comment 1 Matěj Cepl 2008-06-06 04:27:05 EDT
Created attachment 308519 [details]
/var/log/Xorg.0.log
Comment 2 Matěj Cepl 2008-06-06 04:27:33 EDT
Created attachment 308520 [details]
/etc/X11/xorg.conf
Comment 3 Matěj Cepl 2008-06-06 04:31:42 EDT
Maybe related to bug 327941 and bug 377421, but not sure, whether I should call
them duplicates.
Comment 4 Matěj Cepl 2008-06-06 04:32:26 EDT
Created attachment 308521 [details]
output of dmesg
Comment 5 Matěj Cepl 2008-06-06 04:44:47 EDT
Created attachment 308522 [details]
/var/log/messages

(sorry, for compression -- otherwise it would 67MB and my upload connectivity
sucks)
Comment 6 Peter Hutterer 2008-09-16 01:14:33 EDT
The last line of dmesg:
npviewer.bin[32720]: segfault at b6f47044 ip 005e47a0 sp bff6161c error 4 in libpthread-2.8.so[5dd000+15000]


I found this on the ubuntu forums:

"[...] when this happens EVERYTHING locks up. I can't get to the terminal through any means. ALT+PRINTSCREEN+R+E+I+S+U+B doesn't work. Niether does ALT+PRINTSCREEN+O (to shutdown) for that matter (I inevitably have to hit the power switch). Of course, CTTL-ALT-BACKSPACE doesn't work either.I entirely freeze up when this happens (mouse curser frozen, too, of course)."

http://ubuntuforums.org/showthread.php?t=647961&page=3


Could that be it?
Comment 7 Nathanael Noblet 2008-09-16 15:21:56 EDT
So I have similar behaviour. I upgraded from F8 to F9 last night using the DVD/anaconda method. Since then I have had random 'crashes' if you will where the system is still playing music, still updating the screen, but I am unable to do anything. Mouse and keyboard are effectively frozen.

After this happening a few times I tried ssh, and got in. No process was spiking, not high load, nothing. Ran init 3 and init 5, it logged me out and brought me to gdm again to login, but no response from mouse or keyboard. Back to init 3 via ssh, still no keyboard.

I did notice that npviewer.bin was running, which seems related based on the message above, but how that killed both keyboard and mouse is beyond me. there are no error messages in dmesg, Xorg.0.log or messages. I've since removed flash-plugin from Adobe. In case it matters I'm on an Intel Quad Core running the x86_64 version of Fedora 9.
Comment 8 Nathanael Noblet 2008-09-16 15:26:26 EDT
oh one more thing... I wasn't watching a flash video or anything like that, so I don't know why it was in the processlist
Comment 9 Peter Hutterer 2008-09-30 02:52:47 EDT
(In reply to comment #7)
> After this happening a few times I tried ssh, and got in. No process was
> spiking, not high load, nothing. Ran init 3 and init 5, it logged me out and
> brought me to gdm again to login, but no response from mouse or keyboard. Back
> to init 3 via ssh, still no keyboard.

if the keyboard doesn't work on the console either then its probably a kernel problem. That's all I can guess so far.
Comment 10 Matěj Cepl 2008-10-19 18:43:48 EDT
Hasn't happened for some time. Closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.