Bug 450295 - theme uses gnome logo instead of Fedora Logo (also incorrect icon for OOo writer)
theme uses gnome logo instead of Fedora Logo (also incorrect icon for OOo wri...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: echo-icon-theme (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Sourada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 10:22 EDT by You
Modified: 2008-07-23 10:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 10:37:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing both the Gnome logo and the icon for ooo writer (61.12 KB, image/png)
2008-06-06 10:22 EDT, You
no flags Details

  None (edit)
Description You 2008-06-06 10:22:51 EDT
On the Gnome-Menu (Fedora 9), the echo-icon-theme uses the gnome logo instead of
the Fedora logo

Steps to Reproduce:
1. Install echo-icon-theme
2. Use icon theme
3. Look in top right hand corner of screen
  
Actual results:

The gnome logo is shown

Expected results:

The Fedora Logo

Additional info:

This bit should probably be a separate bug, but under the echo icon theme, calc,
Draw and Impress use their official ooo.o icons. Writer uses the text document
icon. IMO this should also use the official icon.
Comment 1 You 2008-06-06 10:22:51 EDT
Created attachment 308535 [details]
screenshot showing both the Gnome logo and the icon for ooo writer
Comment 2 Martin Sourada 2008-06-07 11:00:49 EDT
As for the gnome logo, it is here because we droped the clearlooks dependency in
favour of gnome-icon-theme, which does not ship with the Fedora logo for the
menu. I don't necessarily think this is bug, but we need a solution for that -
use some custom logo (e.g. create echo-icon-theme logo for that purpose), use
echoised gnome logo (would it violate any copyrights/trademarks?) or use plain
fedora logo (AFAIK we cannot echoise it due to trademark issues)? If Fedora
logo, it how to include it, I don't think it can go directly to the Echo icon
theme because IIRC everything that has fedora logo in it must go to the
fedora-logos package :-/

As for the openoffice issue, I need to confirm where's the problem (perhaps
wrong symlink?), for which I need to install openoffice first...

What version of echo-icon-theme do you use?
Comment 3 You 2008-06-07 11:15:45 EDT
echo-icon-theme-0.3.1-2.fc9

I also tried rawhide and it had the same issues (I reverted as I prefer the old
pc icon...), but IMO it is important for Fedora to use the Fedora logo.

Is it possible (atleast in Fedora) for the echo to check whether Fedora logo's
exists and then use the fedora icon from there?

I think there are inheritance rules, ie if icon exists in echo, use it. If not,
use it from another theme. is it possible to have fedora logo's higher in the
chain then the gnome icon theme.

As for the ooo icons, the fedora default replaces all the icons with bluecurve
replacements. Other themes replace none. IMO this is an all or nothing
operation, otherwise the theme loses its effect. (besides that document icon
seems to be more for a document than for an aplication...)

thanks for taking the time to look into this.
Comment 4 Martin Sourada 2008-06-07 12:48:16 EDT
I've fixed the openoffice part in git

http://git.fedorahosted.org/git/?p=echo-icon-theme;a=commit;h=66470923be04a1176efa3b3224cda98e0d4da6eb

expect it to be fixed in Fedora < Rawhide when we release echo-icon-theme-0.3.2
(see https://fedorahosted.org/echo-icon-theme/roadmap). In current rawhide
(http://koji.fedoraproject.org/koji/buildinfo?buildID=48625) this problem should
not be present, because we use iconnaming utils to create symlinks.

As for the main-menu icon, I'll mention this matter on the art-list and we'll
hopefully discuss what the best approach might be, AFAIK there are only these
options:

 a) fallback to fedora icon theme instead of gnome-icon-theme
 b) once is Echo default in Fedora, update fedora icon theme to fallback to echo
instead of mist and make it default
 c) use destkop/OS agnostic icon
Comment 5 Martin Sourada 2008-07-23 10:37:46 EDT
Forgot to close this bug :) We solved both issues, for logo we use
echo-icon-theme logo, which will be replaced by Fedora logo when echo-icon-theme
is made Fedora default.

Note You need to log in before you can comment on or make changes to this bug.