Bug 4503 - gdb-4.18-2 seems to have thread problems
gdb-4.18-2 seems to have thread problems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: gdb (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-13 00:48 EDT by Brian Ryner
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-19 00:13:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ryner 1999-08-13 00:48:15 EDT
I noticed this problem when trying to use gdb with mozilla.
I got messages like:

Program received signal ?, Unknown signal.
0x2aeb31bb in __sigsuspend (set=0x7fffebf8)

Continuing at this point seems to hang both gdb and the
app.  In a possibly related matter, I used the command:

handle SIG32 nostop

with gdb 4.17. 4.18 seems to complain that it doesn't know
what SIG32 is.  I think this might be a thread problem
because I am not seeing the [New thread] messages like in
4.17.
Comment 1 Jim Kingdon 1999-08-19 00:13:59 EDT
Try gdb-4.18-3 and let me know how it works.  gdb-4.18-2 has no thread
support whatsoever.

Note You need to log in before you can comment on or make changes to this bug.