Bug 450303 - libvirt: please default to auth_admin in PolicyKit configuration
Summary: libvirt: please default to auth_admin in PolicyKit configuration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-06 15:23 UTC by Tomas Hoger
Modified: 2008-11-04 11:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-04 11:08:43 UTC
Type: ---


Attachments (Terms of Use)

Description Tomas Hoger 2008-06-06 15:23:56 UTC
PolicyKit configuration for action org.libvirt.unix.manage currently defaults to
auth_self_keep_session, allowing user to authenticate using his/her own password
to use privileged libvirtd services.  This default was picked up to mimic sudo
like behavior.

However, such decision should probably be left to the system administrator and
default policy should be safe, i.e. use auth_admin_keep_session instead. 
Administrator can easily override such default when needed using PolicyKit
configuration files / tools.

Comment 1 Daniel Berrangé 2008-07-09 09:47:11 UTC
Patch posted upstream

http://www.redhat.com/archives/libvir-list/2008-July/msg00117.html



Comment 2 Daniel Berrangé 2008-11-04 11:08:43 UTC
This change was incorporated in libvirt 0.4.5 release


Note You need to log in before you can comment on or make changes to this bug.