Bug 450311 - request for enhancement (rfe)
request for enhancement (rfe)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 12:29 EDT by Bernhard Breytenbach
Modified: 2013-07-02 19:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 03:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Breytenbach 2008-06-06 12:29:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0

Description of problem:
I dont think im doing this right but I guess there is only one way to find out...

Im trying to get my Canon PowerShot SX100 IS to work. But its only available in the new version of libgphoto2-2.4.1

When I run yum update gphoto2-2.4.0 seems to be the latest one. I asked about this in the fedora IRC channel and they said I should post a rfe...

I hope im doing this right...

Version-Release number of selected component (if applicable):
yum install gphoto

How reproducible:
Always


Steps to Reproduce:
1. Plug Canon PowerShot SX100 IS into USB port (under gnome desktop)
2. Turn on and wait for Camara Import to start.
3. Camara import gives following error
"An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Operation not permitted). Make sure no other program or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device."
4. Search for Canon PowerShot SX100 IS and see that its not on the list.
5. Check http://www.gphoto.org/proj/libgphoto2/support.php and see that it is on their latest list.

Actual Results:
I realized that I need the latest version of gphoto2 and used yum install/update gphoto2

Expected Results:
It should have downloaded the newest version of gphoto2 with libgphoto2

Additional info:
I think im posting this in the wrong place... Notes on how I should go about this would be kindly appreciated.

Thanks
Comment 1 Jindrich Novy 2008-06-12 03:34:47 EDT
gphoto2 is now updated to 2.4.1 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.