Bug 450329 - rsyslog tries to be helpful and translate oopses, but actually destroys them instead
rsyslog tries to be helpful and translate oopses, but actually destroys them ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
9
All Linux
low Severity urgent
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
http://www.kerneloops.org/raw.php?raw...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 13:59 EDT by Arjan van de Ven
Modified: 2008-06-17 23:14 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.16.1-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-17 23:14:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arjan van de Ven 2008-06-06 13:59:59 EDT
Description of problem:

Fedora's rsyslog package seems to have been configured to "translate" oopses the
kernel spits out. Unfortunately this is totally misguided and in fact harmful.

1) The kernel, since 2.6.0 (but also in RH and Fedora's kernel since 2.4.7)
*already* does any and all needed translations.

2) rsyslog uses partial information to try to translate AGAIN. But it has less
information than the kernel has, so is doing a rather poor job.

3) the kernel tends to both give the raw AND the translated information, for the
cases where having access to both is essential in diagnosing the bugs.
Unfortunately, rsyslog then comes in and decides to translate *AGAIN* the data
that was essential to have in raw form, but does not retain the raw data.



Look at the attached URL for how silly this is; for diagnosing bugs like this we
NEED the EIP value, as well as the translation. Thankfully the kernel already
gives you both... but rsyslog removes the untranslated value by a
again-translated one.

PLEASE fix this in an updated package; this bug is hindering the diagnostics and
fixing of various kernel bugs.
Comment 1 Tomas Heinrich 2008-06-09 12:08:44 EDT
Hi Arjan,

given the circumstances, it seems logical to change the default behaviour directly in 
the upstream package. I've proposed this change on the mailing list (http://
lists.adiscon.net/pipermail/rsyslog/2008-June/000846.html), you're welcome to comment.
Comment 2 Fedora Update System 2008-06-17 08:13:06 EDT
rsyslog-3.16.1-2.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-06-17 23:14:27 EDT
rsyslog-3.16.1-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.