Bug 450352 - squid-3.0.STABLE1-build.patch only patches generated files
squid-3.0.STABLE1-build.patch only patches generated files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 17:34 EDT by Elmar Hoffmann
Modified: 2014-11-09 17:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 06:06:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch autotools source files to achieve same results as squid-3.0.STABLE1-build.patch (4.52 KB, patch)
2008-06-06 17:34 EDT, Elmar Hoffmann
no flags Details | Diff

  None (edit)
Description Elmar Hoffmann 2008-06-06 17:34:11 EDT
Description of problem:
squid-3.0.STABLE1-build.patch only patches autotools-generated files without
patching their sources, too.
In case of src/Makefile.in it even makes changes to the (un)install-dataDATA
targets that obviously aren't the result of Makefile.am changes.

As a result, when making custom packages that include additional patches that
patch autotools source files only/conflict in patching generated files due to
different autotools versions used, rerunning autotools to generate files
including all the changes (to in turn generate a patch from) fails, dropping all
the changes from squid-3.0.STABLE1-build.patch.

The attached patch fixes these issues, but only patches the Makefile.am files
(as my trees have additional patches before the Fedora ones and I have different
autotools anyway (backporting to FC8)).
To get a replacement for squid-3.0.STABLE1-build.patch, you'd have to run
'./bootstrap.sh && rm -rf autom4te.cache lib/libTrie/autom4te.cache' before diffing.

Version-Release number of selected component (if applicable):
7:3.0.STABLE2-3
Comment 1 Elmar Hoffmann 2008-06-06 17:34:11 EDT
Created attachment 308572 [details]
patch autotools source files to achieve same results as squid-3.0.STABLE1-build.patch
Comment 2 Jiri Skala 2008-08-15 08:44:52 EDT
Is there any reason to move conf file from the /etc path?

The squid-3.0.STABLE1-build.patch patches really autotools-generated file. The reason of this is that Makefile.in is contained in the tarball and build process uses tarball's Makefile.in. Therefore your Makefile.am changes was not applied - no due to squid-3.0.STABLE1-build.patch.
Comment 3 Jiri Skala 2008-10-07 06:06:20 EDT
The Makefile.in is the right file to patch in accordance to guidelines.

I optimized and repaired "build" patch and I extended the patch also to patch Makefile.am.
Comment 4 Elmar Hoffmann 2008-10-07 12:33:41 EDT
Yes, the point was never that the build as is was wrong, just that it made adding 3rd-party patches in custom packages derived from the Fedora one considerably more tedious.
So, thank you for making my life a bit easier. ;)

Note You need to log in before you can comment on or make changes to this bug.