Bug 450354 - packagekit won't open
packagekit won't open
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 17:51 EDT by Bill C. Riemers
Modified: 2008-06-09 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 12:29:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill C. Riemers 2008-06-06 17:51:26 EDT
Description of problem:

When I click on Add/Remove programs I get an icon that says "Starting
Add/Remove" but then nothing ever starts.

This was working for me yesterday, the only thing that has changed is since
yesterday I logged out and rebooted my computer after installing the rawhide
version of packagekit.

Version-Release number of selected component (if applicable):

gnome-packagekit-0.2.2-2.20080529.fc10.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Good question.  On my computer it reproduces simply by trying to open it.
2.
3.
  
Actual results:

Nothing happens.

Expected results:

Add/Remove program dialogue opens.

Additional info:

I am also having problems with gnome-panel, in that "edit menu" also fails to
open.  This problem might be related.
Comment 1 Bill C. Riemers 2008-06-06 17:57:54 EDT
This may be related to bug #450355.
Comment 2 Bill C. Riemers 2008-06-09 10:17:52 EDT
It looks like this is not related to bug #450355.  I recovered from that bug by
restoring my home directory from backup, but this problem persists.  I've tried
reverting back to version 0.1.12-12.20080430.fc9.  That version of packagekit
works normally.   So it looks like this problem only occurs in 0.2.2-2.20080529.

What is the command line to start packagekit from a terminal, so I can see if
there are any helpful diagnostic messages?

Bill
Comment 3 Bill C. Riemers 2008-06-09 10:50:54 EDT
OK.  I found the commandline.  It looks like there is a missing symbol.  My
guess is there is a dependency problem:

[docbill@hartnell ~]$ gpk-application
gpk-application: symbol lookup error: gpk-application: undefined symbol:
pk_control_new

Comment 4 Bill C. Riemers 2008-06-09 11:02:10 EDT
I managed to get the GUI to work again with:

 sudo yum update --enablerepo=rawhide yum-packagekit

This installed:

PackageKit-0.2.2-2.20080529.fc10.x86_64
yum-packagekit-0.2.2-2.20080529.fc10.x86_64
PackageKit-libs-0.2.2-2.20080529.fc10.x86_64

So this is obviously a dependency problem.  

gnome-packagekit-0.2.2-2.20080529.fc10.x86_64

needs to depend on versions of PackageKit-lib and PackageKit >= 0.2.2-2.20080529

Bill
Comment 5 Robin Norwood 2008-06-09 12:29:08 EDT
Thanks for the bug report - looks like the dep issue is fixed in
gnome-packagekit-0.2.3-2.20080609.fc10.i386, built a few minutes ago.

Note You need to log in before you can comment on or make changes to this bug.