This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450361 - firefox will not start on kde desktop, using r128 X driver
firefox will not start on kde desktop, using r128 X driver
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 20:32 EDT by Herbert Carl Meyer
Modified: 2008-10-28 10:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 10:40:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herbert Carl Meyer 2008-06-06 20:32:21 EDT
Description of problem:

from a kde session I cannot start firefox. clicking a menu item produces a
bouncing cursor that goes away without starting firefox, opening a konsole and
starting firefox from the command line produces an error message.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. start a kde session
2. open a konsole
3. enter firefox to the command line
  
Actual results: error message:
[hmeyer0002@evilgnome ~]$ firefox
/usr/lib/firefox-3.0b5/run-mozilla.sh: line 131:  8627 Floating point
exception"$prog" ${1+"$@"}

Expected results:
firefox start

Additional info:
i also cannot start gedit from konsole, "floating point error"
I do not know what to enter this bug against, firefox or kde-workspace. Firefox
works in a gnome session.
Comment 1 Matěj Cepl 2008-07-22 06:21:58 EDT
What actually "$prog" ${1+"$@"} is supposed to mean? Shouldn't it be "$prog"
${1:+"$@"} (even that doesn't make much sense to me though)?
Comment 2 Herbert Carl Meyer 2008-08-30 11:56:10 EDT
Makes little sense to me either. However, the firefox script works on the gnome and xfce desktops. Evolution fails with a similar errors.
I suspect it has to do with the rage128 hardware in this laptop. The X drivers (r128 and vesa) do not work well.
End result is the kde desktop is unusable on this system. kde programs work fine on the other desktops.
This is a rawhide system, keep very up to date. No improvements.
Comment 3 Herbert Carl Meyer 2008-08-31 10:08:52 EDT
Complete misdiagnosis. Problem is with konsole. After changing Xdriver from vesa to r128 to improve performance (no improvement), I got a floating point exception to an "exit" command from konsole.
I had tried konsole because firefox and evolution will not start from kde4 menus or destop start plasmoids. I thought konsole messages would help diagnose.
I have poked around to see if .kderc or something related contain garbage. Looks normal.
The $prog stuff is to allow debugging of firefox with gdb or ddd or something. Before run-mozilla.sh there is a firefox script that parses args, putting debug related stuff first, then calling run-mozilla.sh
Konsole is borked, for unknown reasons. Any other suggestions ?
Comment 4 Matěj Cepl 2008-09-01 09:45:53 EDT
Reassigning to KDE folks. I have no clue.
Comment 5 Kevin Kofler 2008-09-01 09:50:01 EDT
Me neither, I'm afraid. :-(
I don't understand at all why Konsole would be triggering FPEs. Are you sure your hardware is OK?
Comment 6 Ngo Than 2008-09-01 10:13:48 EDT
it sounds a hardware problem for example CPU overclocking?
Comment 7 Rex Dieter 2008-09-06 14:21:09 EDT
or an issue with the r128 X driver (since this apparently only started occuring after starting to uses it).
Comment 8 Ngo Than 2008-09-08 08:52:32 EDT
does the problem show up if you use the vesa driver?
Comment 9 Herbert Carl Meyer 2008-09-28 17:27:11 EDT
Sorry, I have been busy. I changed to the vesa driver, and the problem continued. I suspect the problem is actually with the bash shell under kde. I tried konsole after I could not start firefox from the kde menus, to see if the shell gave me any diagnostic info. Some programs, like konqueror, will start from the kde menu, and many, like firefox and evolution, will not. I have tried both firefox and evolution from kconsole and I get fpe's. I suspect the programs I cannot start from the menus start using shell procs, and the ones I can start are bare executables.
Is there somewhere else the error msgs from the attempts to start from kde menu would be logged ?
Comment 10 Herbert Carl Meyer 2008-10-28 10:40:19 EDT
After recent updates, kde desktop is working. Right now, kdebase is at 4.1.2-5.fc10 and kdeworkspace is at 4.1.12-7.fc10.

Note You need to log in before you can comment on or make changes to this bug.