Bug 450385 - fsck fails on volumes from qlogic fibre channel SAN
fsck fails on volumes from qlogic fibre channel SAN
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.8
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-07 07:18 EDT by Ingvar Hagelund
Modified: 2009-03-11 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 12:57:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingvar Hagelund 2008-06-07 07:18:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; nb-NO; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

Description of problem:
/var/lib/mysql is mounted from /dev/mapper/db01_mysql. db01_mysql is a volum aliased from multipath.conf. The volume is a SAN volume, made available by a QLogic ISP2432-based 4Gb Fibre Channel card (kernel modules qla2400, qla2323, qla2xxx loaded from initrd).

The volume contains normal mysql data on a ext3 filesystem. It is listed in /etc/fstab, like this:

/dev/mapper/db01_mysql  /var/lib/mysql          ext3    defaults 1 2

/usr is on a separate volume, and is thus not mounted when rc.sysinit tries to fsck the volume at boot time. When fsck runs, it fails, probably because of missing libraries. I see that at least libsysfs lacks from /lib64, and perhaps other libraries as well.

fsck on the volume after the system has booted works fine. Same goes for mounting the volume. Summarized, I guess that missing libraries or other files from /usr are the cause of fsck failing at boot time.

[root@sykehus ~]# lsmod | grep qla
qla2400               206913  0 
qla2322               139201  0 
qla2xxx               193057  6 qla2400,qla2322
scsi_transport_fc      12097  1 qla2xxx
scsi_mod              145041  7 sr_mod,usb_storage,libata,megaraid_sas,qla2xxx,scsi_transport_fc,sd_mod

# grep qla /etc/modprobe.conf
alias scsi_hostadapter qla2xxx
alias scsi_hostadapter2 qla2322

Ugly workaround: Mark the volume as not to be checked or mounted at boot, and mount it in the mysqld init script instead.

The system is in heavily production, and can't be test booted at will, so it's a bit tricky to experiment more to resolve the bug in our end.

Ingvar


Version-Release number of selected component (if applicable):
initscripts-7.93.31.EL-2

How reproducible:
Always


Steps to Reproduce:
1. Pur /usr on a separate volume
2. Put another filesystem on a multipath.conf aliased device mapper volume, and list it for fsck/mounting in fstab
3. reboot

Actual Results:
fsck fails

Expected Results:
fsck checks the volume

Additional info:
Comment 1 Bill Nottingham 2008-06-09 09:43:17 EDT
What is the specific failure?
Comment 2 Bill Nottingham 2009-03-11 12:57:58 EDT
Closing, no response.

Note You need to log in before you can comment on or make changes to this bug.