Bug 450388 - Update to epstopdf 2.9.5gw requested
Update to epstopdf 2.9.5gw requested
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tetex (Show other bugs)
5.2
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Jindrich Novy
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-07 08:13 EDT by Peter Klotz
Modified: 2013-07-02 19:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-26 11:30:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Klotz 2008-06-07 08:13:25 EDT
Description of problem:

RHEL5.2 package tetex-3.0-33.2.el5_1.2 includes epstopdf 2.9.3draft. This
version reproducible fails on several .eps files, especially in conjunction with
doxygen/dot generated .eps files.

The changelog for epstopdf 2.9.5gw contains this important fix:

2005/10/06 v2.9.5gw (Gerben Wierda)
  * Fixed a horrendous bug in the (atend) handling code

When using this version the combination doxygen/dot works flawless.

Therefore I request the upgrade of epstopdf to version 2.9.5gw for RHEL5.3.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2009-02-11 14:37:05 EST
Quality Engineering Management has reviewed and declined this request.  You may
appeal this decision by reopening this request.
Comment 3 Mattias Ellert 2011-06-29 01:33:21 EDT
This bug is really disruptive. When building documentation as part of a package build using pdflatex this often fails due to this script being buggy. I can work around this by carrying a working copy of the script in each SRPM that calls pdflatex and set up the PATH so that this copy is picked up instead of the system's version, but this is very hackish - I would really prefer if this was fixed in the system. I currently have around 30 SRPMS for EPEL that contain a copy of this script because this bug is not fixed. This bug is easy to fix and should have been fixed years ago when it was first reported.
Comment 6 RHEL Product and Program Management 2012-06-11 21:05:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 Benjamin Kosnik 2013-01-16 12:56:42 EST
This has been fixed for fedora 18, where a much-improved tex subsystem based on texlive-2012 has replaced the older texlive-2007 base found in earlier Red Hat releases, including RHEL5 and RHEL6.

epstopdf-2.18 is the active version for this re-base.

It seems likely that this version of epstopdf will be in RHEL7. So, even though this looks like it will not be fixed in RHEL 5/6, future product releases will fix this bug.
Comment 8 Mattias Ellert 2013-01-17 10:16:27 EST
Actually this has been fixed in Fedora since Fedora 7, which is a long time ago. It is also fixed in RHEL 6. This bug is about the version in RHEL 5.

That the bug is fixed in RHEL 6 and of course also will not be present in RHEL 7 is irrelevant for the reported problem, which is that the bug is present in RHEL 5. When building packages for EPEL 5, only software in RHEL 5 and EPEL 5 may be used as build dependencies. So that this bug is fix in version in other distributions does not help whatsoever.

The epstopdf program is a perl script, there is no need to update the full tetex package to texlive to fix it. You can simply create a patch with the differences between the old version and the new version and apply it when making a new release of the old version for RHEL 5. You do occasionally rebuild tetex for RHEL 5, so why was this not done on one of these occasions? It is such a simple thing to do.
Comment 9 Jan Zeleny 2013-03-26 11:30:19 EDT
RHEL5 is in very late stage of its development cycle and only critical fixes are accepted. I'm very sorry to say that rebase of epstopdf is not a critical fix, despite the bug being irritating. I'm closing this bug as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.