Bug 450389 - network doesn't work after init 3, init 5
network doesn't work after init 3, init 5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 446395
  Show dependency treegraph
 
Reported: 2008-06-07 08:30 EDT by Alec Leamas
Modified: 2014-03-16 23:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 09:48:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
br0 sysconfig script (167 bytes, text/plain)
2008-06-07 08:34 EDT, Alec Leamas
no flags Details

  None (edit)
Description Alec Leamas 2008-06-07 08:30:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
I have four network interfaces: loopback, br0, eth0 and vbox5. Br0 is a bridge configured to contain eth0 and vbox5.

After booting the machine, the network is non-existent, no routes, no usable interfaces. Adding a "service network restart" in /etc/rc.local fixes this for the moment.

After a init3 - init 5 cycle the network is also down. 

Version-Release number of selected component (if applicable):
initscripts-8.76.2-1.x86_64

How reproducible:
Always


Steps to Reproduce:
1.Boot machine without "service network restart" in /etc/rc.local
2. Watch output from e. g., "netstat -nr" - no interfaces, no routes.
or
1. Start machine with "service network restart" in /etc/rc.local.
2. # init 3
3. # init 5  Note messages about interfaces brought down, but not up.

Actual Results:
In both cases: all interfaces except loopback deactivated, no routes etc.

Expected Results:
Interfaces up, routes in place etc.

Additional info:
Using fixed IP addresses, no NetworkManager.

The problems started after upgrading from rawhide to F-9, it might possibly be a upgrade/anaconda issue.

System updated as of today.
Comment 1 Alec Leamas 2008-06-07 08:34:23 EDT
Created attachment 308609 [details]
br0 sysconfig script

The bridge, the only thing I can think of which is not standard
Comment 2 Alec Leamas 2008-06-07 11:43:31 EDT
OK, seem to have found it. The main problem is missing links to
/etc/init.d/network in /etc/rc[35].d This in turn is due to problems w
chkconfig, which does not generate the expected S10network links in these dirs.
Manually adding /etc/rc[35].d/S10network resolves the basic problem, and the
login screen comes up as expected.

This issue with missing links and chkconfig has been discussed elsewhere, don't
remember right now. Sorry.

Details: /etc/init.d contains a line "# chkconfig: - 10 90" which to my
understanding implies that "chkconfig network reset" should create S10network
and K90network  links in the /etc/rc[1-5].d directories. However, only the
K90network links are in place after "chkconfig network reset". I don't find the
documentation for how chkconfig interprets the '-' which should indicate in
which runlevels the S10newtwork links should be created though.
Comment 3 Alec Leamas 2008-06-07 12:57:14 EDT
OOps, re-reading the chkconfig manpage i recognize that the '-' means that the
network shouldn't be started in any runlevel. So the manual fix basically
creates startup scripts which shoould be there? Is this because I havn't
NetworkManager enabled?!...
Comment 4 Bill Nottingham 2008-06-09 09:48:10 EDT
From the release notes:

http://docs.fedoraproject.org/release-notes/f9/en_US/sn-System-Services.html#NetworkManager
...
 Fedora 9 features NetworkManager. NetworkManager 0.7 provides improved mobile
broadband support, including GSM and CDMA devices, and now supports multiple
devices, ad-hoc networking for sharing connections, and the use of system-wide
network configuration. It is now enabled by default on all installations. When
using NetworkManager, be aware of the following:

    *  NetworkManager does not currently support all virtual device types. Users
who use bridging, bonding, or VLANs may need to switch to the old network
service after configuration of those interfaces. 
...

Note You need to log in before you can comment on or make changes to this bug.