This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450397 - RHEL5.1: Firewall settings for multicast address poorly explained
RHEL5.1: Firewall settings for multicast address poorly explained
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Cluster_Administration (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Paul Kennedy
Content Services Development
: Documentation
Depends On:
Blocks: 458882 458884
  Show dependency treegraph
 
Reported: 2008-06-07 10:47 EDT by Martin Waite
Modified: 2015-04-19 20:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 17:04:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Revised content in PDF and HTML printed to PDF. (202.63 KB, application/zip)
2008-08-12 17:01 EDT, Paul Kennedy
no flags Details

  None (edit)
Description Martin Waite 2008-06-07 10:47:07 EDT
Description of problem:

Documentation of the iptables settings are incorrect for cluster in RHEL 5.1.

Version-Release number of selected component (if applicable):

Cluster_Administration RHEL 5.1 (2008-01-10T14:58)

How reproducible:

Follow the instructions for building a cluster using the iptables settings in
chapter 2, and the luci instructions in chapter 3.  The nodes will reboot,etc.
but will not join.  

Steps to Reproduce:
1.  Apply the iptables settings described in chapter 2, section 2.1 and 2.2 -
changing the IP address as appropriate for your nodes. 
2.  Install and start ricci and luci as per chapter 3, section 2.
3.  Create and configure the cluster as per chapter 3, section 3.
  
Actual results:

We see the nodes reboot, etc., but the final join stage times out.

Expected results:

The cluster should start with all nodes joined.

Additional info:

The problem is with the firewall settings for the multicast socket.  The
document gives us:

iptables -A INPUT -i 10.10.10.200 -m multiport -m state --state NEW -p udp
-s 10.10.10.0/24 -d 10.10.10.0/24 --dports 5404,5405 -j ACCEPT

This cannot work:  the multicast socket has to be in the range 224.0.0.0 to
239.255.255.255.   The firewall needs to be set so that the destination is the
multicast address, with the source as the unicast IP address of the interface.

On my configuration, I used the command:

iptables -A INPUT -s 192.168.2.0/255.255.255.0 -d 224.0.0.0/224.0.0.0 -p udp -m
state --state NEW -m multiport --dports 5404,5405 -j ACCEPT

By default, the cluster will be assigned a multicast address that is based on a
hash of the cluster name, and so will not be known in advance (hence the /4
setting on the destination).  Perhaps the example in the manual should use a
fixed multicast address and apply more specific firewalling to it.
Comment 1 Paul Kennedy 2008-08-12 17:01:19 EDT
Created attachment 314141 [details]
Revised content in PDF and HTML printed to PDF.

Revised content in PDF and HTML printed to PDF is included.
Comment 2 Paul Kennedy 2008-08-12 17:03:32 EDT
Revised content is attached in both PDF and HTML output formats. Revised content has been reviewed and approved by subject matter expert. Fixed in 5.3 branch. Will merge with published versions.
Comment 3 Paul Kennedy 2008-08-13 17:04:12 EDT
Problem will be fixed in RHEL 5.3 and RHEL 5.2 versions.

Note You need to log in before you can comment on or make changes to this bug.