Bug 450398 - mkinitrd fails to include support for ext3 fs when root fs is type XFS
mkinitrd fails to include support for ext3 fs when root fs is type XFS
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-07 11:33 EDT by John Damm Sørensen
Modified: 2014-03-16 23:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-10 11:22:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Damm Sørensen 2008-06-07 11:33:20 EDT
Description of problem:
When root filesystem is of type XFS, mkinitrd fails to include ext2, ext3 and
ext4dev modules.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.52-2.fc9.i386
any FC9 kernel

How reproducible:
100%

Steps to Reproduce:
1.mkinitrd
2.reboot

  
Actual results:

System fails to start, because it cannot mount the ext3 filesystems(/boot and /home)

Expected results:

Make mkinitrd include all necessary modules.
Additional info:

Workaround is to run mkinitrd with additional arguments:
-preload=ext2 --preload=ext3 --preload=ext4dev
Comment 1 Jeremy Katz 2008-06-13 13:58:10 EDT
They should then later get loaded when the filesystem tries to be mounted.  What
does your /etc/fstab look like?
Comment 2 John Damm Sørensen 2008-06-13 14:36:00 EDT
UUID=e4e9bf00-4a21-48fe-9d8d-b36ebc33d574 /                       xfs     defaul
ts        1 1
UUID=dc20a23b-44a7-4f1a-9ebd-b73111e6edea /boot                   ext3    defaul
ts        1 2
UUID=2f90cf80-334c-11dd-9a1c-00265411f72f /home                   ext3    defaul
ts        1 2
UUID=ade3ac12-334d-11dd-ab99-00265411f72f  /var/www/html          ext3    defaul
ts        1 2
UUID=42467476-339d-11dd-9ceb-00265411f72f  /tmp   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
UUID=2ba8cdf5-764f-475e-bd69-4b9afb053e96 swap                    swap    defaul
ts        0 0

Error message is that the sysyem cannot resolve the UUID for the ext3 file systems.
Comment 3 John Damm Sørensen 2008-06-16 06:37:39 EDT
I have switched to a different motherboard and eliminated a SCSI controller and
a SCSI disk, and now system boots OK.
Comment 4 Peter Jones 2008-07-10 11:13:05 EDT
These modules aren't needed by the initrd; rc.sysinit mounts those filesystems.
 As such, this appears to be an initscripts bug.
Comment 5 Bill Nottingham 2008-07-10 11:22:30 EDT
initscripts doesn't need to do anything for the modules - they're on the normal
system at that point. Closing re comment #3.

Note You need to log in before you can comment on or make changes to this bug.