Bug 450415 - Investigate adding the Pulse-Per-Second (PPS) patch or equivalent
Investigate adding the Pulse-Per-Second (PPS) patch or equivalent
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Real Time Maintenance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-07 21:17 EDT by Clark Williams
Modified: 2009-09-23 12:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 12:22:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clark Williams 2008-06-07 21:17:28 EDT
Description of problem:

Many of our customers have expressed a desire to synchronise multiple systems in
a datacenter to sub-millisecond time resolutions. Currently, NTP is unable to
maintain this level of synchronization. We should investigate the utility of
combining a GPS precision time source with either a multi-drop serial interface
or  a dedicated ethernet interface, as a periodic update to NTP.
Comment 1 Clark Williams 2008-06-07 21:19:52 EDT
Ah re-reading my above, I realized that I didn't state that I'm aware that the
current PPS patch is unsuitable for inclusion. We should look at starting from
that and possibly morphing it into a general purpose solution that:

1. Doesn't add it's own system calls
2. Possibly provides a clocksource
3. Doesn't suck
Comment 2 Clark Williams 2008-11-05 16:05:59 EST
Some links for consideration

LinuxPPS website:
      http://wiki.enneenne.com/index.php/LinuxPPS_support

Seventh repost of PPS patch series to LKML:
      http://linux.derkeiler.com/Mailing-Lists/Kernel/2008-09/msg04640.html
Comment 3 Matt Castelein 2009-02-18 18:02:44 EST
Would this just be for RHEL, or would Fedora benefit as well?  I would like to have this functionality without breaking kernel updates.
Comment 4 Clark Williams 2009-02-18 19:07:25 EST
At present we're just talking about it for the MRT RT (realtime) kernel. I don't know of any plans to add it to RHEL or Fedora, since it's not upstream yet.
Comment 5 Beth Uptagrafft 2009-09-22 17:29:31 EDT
Clark, is this still something we want to pursue?
Comment 6 Clark Williams 2009-09-23 12:22:06 EDT
PPS has been added to the 2.6.31 upstream kernel. closing

Note You need to log in before you can comment on or make changes to this bug.