Bug 450423 - kernel-xen-doc and kernel-doc packages have conflicting files
kernel-xen-doc and kernel-doc packages have conflicting files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-08 00:50 EDT by i fennell
Modified: 2014-01-21 18:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 05:15:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console commands and output , and yumex error log in locale=UTF-8 (428.30 KB, text/plain)
2008-06-08 00:50 EDT, i fennell
no flags Details

  None (edit)
Description i fennell 2008-06-08 00:50:46 EDT
Description of problem: update to kernel-doc-2.6.25 cause X application crash


Version-Release number of selected component (if applicable):2.6.25


How reproducible:smart and package manager both fail everytime


Steps to Reproduce:
1.launch update with kernel-xen-2.6-doc-2.6.25.3-1.fc9.noarch already installed
2.select kernel-doc-2.6.25
3.commit and wait for the crash
  
Actual results:
program closes 
no indication what happened, package not installed

Expected results:
report reason for failure

Additional info:
launching from terminal gives X allocation error after closing
yumex run from a terminal manages to log the errors and echo the errors to the
console

works in reverse too:
1) uninstalled kernel-xen-2.6-doc-2.6.25.3-1.fc9.noarch
2) installed  kernel-doc-2.6.25
3) attempted to reinstall kernel-xen-2.6-doc-2.6.25.3-1.fc9.noarch
4) blows up real good (the same)

no log of errors in /var/log/  yum , messages, X11 , warnings
Comment 1 i fennell 2008-06-08 00:50:46 EDT
Created attachment 308632 [details]
console commands and output , and yumex error log  in locale=UTF-8
Comment 2 seth vidal 2008-06-08 07:43:10 EDT
Okay, there's a packaging issue here with the kernel-xen-doc and kernel-doc. The
issue with smart crashing should be filed with smart. Yumex appears to be
behaving correctly. I'm going to reassign this to the kernel folks for comments.
Comment 3 i fennell 2008-06-08 15:51:14 EDT
first package manager is gpk-application 0.1.12 .It and Smart Package Manager
0.52 act the same way. Perhaps it's a common library call.
Should I pass it to both smart and gpk-application?

in fc9 2.6.25.4-30.fc9.x86_64.debug
Comment 4 Chuck Ebbert 2008-06-08 23:48:04 EDT
Should we make kernel-doc and kernel-xen-doc conflicting packages???
Comment 5 i fennell 2008-06-09 15:15:45 EDT
filed 
smart bug 450593
gpk-application 450594
Comment 6 Chuck Ebbert 2008-06-10 15:15:03 EDT
Changing package to kernel-xen. Maybe just killing the kernel-xen-doc package is
a solution?
Comment 7 Mark McLoughlin 2008-07-25 05:15:07 EDT
Killing kernel-xen itself should have done the trick :-)

Note You need to log in before you can comment on or make changes to this bug.