Bug 450425 - screen locking doesn't work (patch attached)
screen locking doesn't work (patch attached)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xfce-utils (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-08 00:58 EDT by D Haley
Modified: 2009-05-02 12:24 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.4.3-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-02 12:24:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Possible replacement for xfloc4 (1.14 KB, text/plain)
2008-06-08 00:58 EDT, D Haley
no flags Details
Possible replacement for xflock4 (1.10 KB, text/plain)
2008-06-08 01:04 EDT, D Haley
no flags Details
gnome-screensaver patch for xflock and /etc/xdg/xfce4/xinitrc (1.44 KB, patch)
2008-08-27 13:20 EDT, Christoph Wickert
no flags Details | Diff
updated gnome-screensaver patch for xflock and /etc/xdg/xfce4/xinitrc (1.44 KB, patch)
2008-08-27 16:40 EDT, Christoph Wickert
no flags Details | Diff

  None (edit)
Description D Haley 2008-06-08 00:58:09 EDT
Description of problem:
Several issues. Screen locking does not work in xfce4 due to incorrect
/usr/bin/xflock4.


Version-Release number of selected component (if applicable):


How reproducible:
Try to lock your screen using the lock applet, or by running xflock4 when you
only have gnome-screensaver installed


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 D Haley 2008-06-08 00:58:09 EDT
Created attachment 308634 [details]
Possible replacement for xfloc4
Comment 2 D Haley 2008-06-08 01:04:06 EDT
Created attachment 308635 [details]
Possible replacement for xflock4

Previous was wrong. With any luck this should be better.
Comment 3 Kevin Fenzi 2008-06-08 13:48:26 EDT
Yeah, there isn't any gnome-screensaver support in Xfce currently...
but I have no objection to adding this and seeing if upstream is interested. 

Currently, xscreensaver is started on login if it's available... 
Comment 4 D Haley 2008-06-08 21:55:22 EDT
There was the command "gnome-screensaver-command" already there, but that needs
to have gnome-screensaver working to start with otherwise nothing happens, this
is the change I made.

The only two issues I have with my modifications is whether using ps to locate
the gnome-screensaver process is the best idea, or if some kind of error should
be added if nothing can be found.
Comment 5 Christoph Wickert 2008-08-27 13:20:05 EDT
Created attachment 315121 [details]
gnome-screensaver patch for xflock and /etc/xdg/xfce4/xinitrc

- check for the screensaver actually running instead of installed ones
- prefer gnome-screensaver if installed
Comment 6 Christoph Wickert 2008-08-27 13:21:29 EDT
(In reply to comment #2)
> Possible replacement for xflock4

This patch looks wrong to me:
1. You are starting gnome-screensaver, but this should already be done on login by /etc/xdg/xfce4/xinitrc.
2. xflock should not look for installed but for running screensavers. See http://bugzilla.xfce.org/show_bug.cgi?id=3770
3. I have modified the patch from that bug so that xflock and /etc/xdg/xfce4/xinitrc prefer gnome-screensaver over xscreensaver if installed because it offers the advantage of user switching.
Comment 7 Christoph Wickert 2008-08-27 16:40:54 EDT
Created attachment 315139 [details]
updated gnome-screensaver patch for xflock and /etc/xdg/xfce4/xinitrc

Updated to work with multiple users logged in
Comment 8 D Haley 2008-08-27 21:38:03 EDT
Screen locking didn't work because gnome-screensaver wasn't being started at login  -- I have not modified my xinitrc. That was the key change in my attachment, unfortunately since this was so long ago, I cannot remember why it wasn't being started :( -- it is possible that your changes to xinitrc.in wil fix this.

What if the process has terminated (eg segfault, gratiuitous use of TERM, ...) why not, if not running, check for existence and then run it? 

I will revisit this in the next couple of days...
Comment 9 Fedora Update System 2009-03-23 17:26:58 EDT
xfce4-session-4.4.3-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xfce4-session-4.4.3-1.fc10
Comment 10 Christoph Wickert 2009-03-23 17:34:16 EDT
Patch from comment # 7  is included in 4.4.3-1
Comment 11 Fedora Update System 2009-04-13 07:13:10 EDT
xfdesktop-4.4.3-1.fc9,gtk-xfce-engine-2.4.3-1.fc9,xfce4-icon-theme-4.4.3-1.fc9,orage-4.4.3-1.fc9,xfwm4-themes-4.4.3-1.fc9,xfce4-mixer-4.4.3-3.fc9,Thunar-0.9.3-1.fc9,Terminal-0.2.8.3-1.fc9,xfce4-session-4.4.3-1.fc9,xfce-utils-4.4.3-1.fc9,xfwm4-4.4.3-2.fc9,xfce4-panel-4.4.3-1.fc9,exo-0.3.4-3.fc9,xfce-mcs-plugins-4.4.3-1.fc9,xfce-mcs-manager-4.4.3-1.fc9.1,xfce4-appfinder-4.4.3-1.fc9,mousepad-0.2.14-1.fc9,libxfce4mcs-4.4.3-1.fc9,libxfcegui4-4.4.3-1.fc9,libxfce4util-4.4.3-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xfdesktop-4.4.3-1.fc9,gtk-xfce-engine-2.4.3-1.fc9,xfce4-icon-theme-4.4.3-1.fc9,orage-4.4.3-1.fc9,xfwm4-themes-4.4.3-1.fc9,xfce4-mixer-4.4.3-3.fc9,Thunar-0.9.3-1.fc9,Terminal-0.2.8.3-1.fc9,xfce4-session-4.4.3-1.fc9,xfce-utils-4.4.3-1.fc9,xfwm4-4.4.3-2.fc9,xfce4-panel-4.4.3-1.fc9,exo-0.3.4-3.fc9,xfce-mcs-plugins-4.4.3-1.fc9,xfce-mcs-manager-4.4.3-1.fc9.1,xfce4-appfinder-4.4.3-1.fc9,mousepad-0.2.14-1.fc9,libxfce4mcs-4.4.3-1.fc9,libxfcegui4-4.4.3-1.fc9,libxfce4util-4.4.3-1.fc9
Comment 12 Fedora Update System 2009-04-13 15:34:13 EDT
xfdesktop-4.4.3-1.fc9, gtk-xfce-engine-2.4.3-1.fc9, xfce4-icon-theme-4.4.3-1.fc9, orage-4.4.3-1.fc9, xfwm4-themes-4.4.3-1.fc9, xfce4-mixer-4.4.3-3.fc9, Thunar-0.9.3-1.fc9, Terminal-0.2.8.3-1.fc9, xfce4-session-4.4.3-1.fc9, xfce-utils-4.4.3-1.fc9, xfwm4-4.4.3-2.fc9, xfce4-panel-4.4.3-1.fc9, exo-0.3.4-3.fc9, xfce-mcs-plugins-4.4.3-1.fc9, xfce-mcs-manager-4.4.3-1.fc9.1, xfce4-appfinder-4.4.3-1.fc9, mousepad-0.2.14-1.fc9, libxfce4mcs-4.4.3-1.fc9, libxfcegui4-4.4.3-1.fc9, libxfce4util-4.4.3-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update xfdesktop gtk-xfce-engine xfce4-icon-theme orage xfwm4-themes xfce4-mixer Thunar Terminal xfce4-session xfce-utils xfwm4 xfce4-panel exo xfce-mcs-plugins xfce-mcs-manager xfce4-appfinder mousepad libxfce4mcs libxfcegui4 libxfce4util'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3521
Comment 13 Fedora Update System 2009-04-13 15:45:10 EDT
xfce4-session-4.4.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-05-02 12:23:51 EDT
xfdesktop-4.4.3-1.fc9, gtk-xfce-engine-2.4.3-1.fc9, xfce4-icon-theme-4.4.3-1.fc9, orage-4.4.3-1.fc9, xfwm4-themes-4.4.3-1.fc9, xfce4-mixer-4.4.3-3.fc9, Thunar-0.9.3-1.fc9, Terminal-0.2.8.3-1.fc9, xfce4-session-4.4.3-1.fc9, xfce-utils-4.4.3-1.fc9, xfwm4-4.4.3-2.fc9, xfce4-panel-4.4.3-1.fc9, exo-0.3.4-3.fc9, xfce-mcs-plugins-4.4.3-1.fc9, xfce-mcs-manager-4.4.3-1.fc9.1, xfce4-appfinder-4.4.3-1.fc9, mousepad-0.2.14-1.fc9, libxfce4mcs-4.4.3-1.fc9, libxfcegui4-4.4.3-1.fc9, libxfce4util-4.4.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.