Bug 450432 - Xorg fails to display with Radeon HD 2400 Pro
Xorg fails to display with Radeon HD 2400 Pro
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-08 06:17 EDT by Patrick Steiner
Modified: 2009-07-14 13:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:31:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (30.06 KB, text/plain)
2008-06-08 06:17 EDT, Patrick Steiner
no flags Details
dmesg log file (31.32 KB, text/plain)
2008-06-08 06:18 EDT, Patrick Steiner
no flags Details
messages log file (205.68 KB, text/plain)
2008-06-08 06:18 EDT, Patrick Steiner
no flags Details
gdm log file (28.36 KB, text/plain)
2008-06-12 03:30 EDT, Patrick Steiner
no flags Details
dmesg log file (31.91 KB, text/plain)
2008-06-12 03:30 EDT, Patrick Steiner
no flags Details

  None (edit)
Description Patrick Steiner 2008-06-08 06:17:34 EDT
Since Fedora 9 my Radeon HD 2400 Pro (RV610) doesn't work anymore.

I cant start initlevel 5. If the xorg-xserver gets started i only see a defect
image of the rhgb. a few seconds later my fedora 9 machine reboots.

i already tried the radeon and the radeonhd xorg driver.

i have attached some log files.
Comment 1 Patrick Steiner 2008-06-08 06:17:34 EDT
Created attachment 308647 [details]
xorg log file
Comment 2 Patrick Steiner 2008-06-08 06:18:01 EDT
Created attachment 308648 [details]
dmesg log file
Comment 3 Patrick Steiner 2008-06-08 06:18:19 EDT
Created attachment 308649 [details]
messages log file
Comment 4 Patrick Steiner 2008-06-11 16:58:13 EDT
I figured out, that this problem is only available with 4gb of ram if i remove 1
ram brick it works (with 2gb ram) without problem.

this problem wasnt available on fedora 8
Comment 5 Patrick Steiner 2008-06-11 17:03:25 EDT
this bug looks very similar should we close one?

https://bugzilla.redhat.com/show_bug.cgi?id=450247
Comment 6 Andy Burns 2008-06-11 19:42:22 EDT
Although they both seem related to 4GB memory, on my machine with the intel
driver it crashes xorg, yours with the radeon driver reboots the machine (kernel
panic?)

I'd rather see some comment from ajax and/or airlied before closing either of them.
Comment 7 Patrick Steiner 2008-06-12 03:27:19 EDT
I found out something more about this problem.

could this be an mtrr problem?

i have attached a dmesg file and my gdm log in both there are mtrr problems like:

error setting MTRR (base = 0xf0000000, size = 0x08000000, type = 1) Invalid
argument (22)
Comment 8 Patrick Steiner 2008-06-12 03:30:16 EDT
Created attachment 309033 [details]
gdm log file
Comment 9 Patrick Steiner 2008-06-12 03:30:45 EDT
Created attachment 309035 [details]
dmesg log file
Comment 10 Patrick Steiner 2008-06-12 16:37:53 EDT
i found a solution for my problem. i dont know if this is a nice idea...

i disabled the memory remap feature in my motherboard bios.

ofter that my ati radeon 2400 pro works
Comment 11 Dave Airlie 2008-06-12 18:54:52 EDT
can you check with your motherboard vendor if they have an updated BIOS for your
motherboard.

I've heard of a few problems with the memory remap and some people mentioned
BIOs upgrades fixed them.
Comment 12 Patrick Steiner 2008-06-13 01:59:44 EDT
i have a asus p5k motherboard with the latest bios 1006. the strange thing is,
that it worked perfect with my fedora 8 system.

is disabling memory remap function a bad idea?

or should i use the x64 version on fedora 9 with my system?

i have 4gb ram and 256mb ram on my ati card
Comment 13 Don Seiler 2008-07-18 14:21:27 EDT
Just a "me too".  I have 4gb RMAN, F9 x86_64 with the Radeon HD 2400 Pro, and I
can only use the vesa driver.  Let me know if I can provide other information.
Comment 14 Don Seiler 2008-07-18 14:24:06 EDT
ugh, that should be "4gb RAM", not "4gb RMAN".  Too much time around Oracle.
Comment 15 Patrick Steiner 2008-07-18 14:29:45 EDT
i have this problems only with 32bit fedora, but if i disable memory remapping
it also works.

now i switched to x86_64 and the radeon card also works with enabled memory
remapping.
Comment 16 Don Seiler 2008-07-18 14:40:23 EDT
Also an FYI that I actually was chatting with airlied in #radeon last night and
he suggested a file a bug at bugs.freedesktop.org, which I did.

https://bugs.freedesktop.org/show_bug.cgi?id=16768
Comment 17 Bug Zapper 2009-06-09 21:28:25 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Bug Zapper 2009-07-14 13:31:42 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.