Bug 450456 - right-click on clock from cairo-dock instantly crashes desktop
right-click on clock from cairo-dock instantly crashes desktop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cairo-dock (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-08 13:58 EDT by John Ellson
Modified: 2008-09-03 08:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 08:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2008-06-08 13:58:22 EDT
Description of problem:
right-click on clock from cairo-dock instantly crashes desktop

Version-Release number of selected component (if applicable):
cairo-dock-1.6.0-0.1.svn1085_trunk.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start cairo-dock
2. mouse over clock
3. right-click
  
Actual results:
desktop crashes, user is logged out

Expected results:
I don't know, but not that.

Additional info:
Comment 1 John Ellson 2008-06-08 14:48:20 EDT
/var/log/Xorg.0.log.old ends with:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x65) [0x479fe5]
1: /lib64/libc.so.6 [0x39a1233040]
2: /usr/bin/Xorg(miHandleValidateExposures+0x6c) [0x4e39fc]
3: /usr/bin/Xorg(UnmapWindow+0x248) [0x4316e8]
4: /usr/bin/Xorg(compFreeClientWindow+0x28f) [0x4fe78f]
5: /usr/bin/Xorg [0x4fa459]
6: /usr/bin/Xorg(FreeResource+0x134) [0x42efc4]
7: /usr/bin/Xorg(compUnredirectWindow+0x83) [0x4fdbe3]
8: /usr/bin/Xorg [0x4facc3]
9: /usr/bin/Xorg [0x4e3faf]
10: /usr/bin/Xorg [0x4e3ebc]
11: /usr/bin/Xorg(miChangeSaveUnder+0x50) [0x4e4050]
12: /usr/bin/Xorg(MapWindow+0x33f) [0x431daf]
13: /usr/bin/Xorg(ProcMapWindow+0x46) [0x445b56]
14: /usr/bin/Xorg(Dispatch+0x364) [0x446394]
15: /usr/bin/Xorg(main+0x45d) [0x42c87d]
16: /lib64/libc.so.6(__libc_start_main+0xfa) [0x39a121e40a]
17: /usr/bin/Xorg(FontFileCompleteXLFD+0x279) [0x42bc59]

Fatal server error:
Caught signal 11.  Server aborting

(II) UnloadModule: "kbd"
(II) UnloadModule: "mouse"
(II) Logitech USB-PS/2 Optical Mouse: Close
(II) UnloadModule: "evdev"
(II) Macintosh mouse button emulation: Close
(II) UnloadModule: "evdev"
Comment 2 Mamoru TASAKA 2008-06-09 02:34:42 EDT
Well, actually "X" seems to be crashing. not cairo-dock...

In such cases, this is usually a bug in X.
http://www.jwz.org/xscreensaver/faq.html#server-crash
Comment 3 Mamoru TASAKA 2008-09-03 07:15:45 EDT
Hi,
If you still see this issue reproducibly? If so please
- attach your xorg.conf
- attach the complete Xorg.0.log with crash is reproduced
- and Xorg.0.log when you launch X with xorg.conf completely removed
and perhaps I will ask X maintainers.
Comment 4 John Ellson 2008-09-03 08:21:34 EDT
I can't reproduce this problem today (Rawhide before today's updates).
So the problem seems to be fixed.

Now when I right click on the clock I get a menu.

Thanks for following up on this.
Comment 5 Mamoru TASAKA 2008-09-03 08:42:15 EDT
Okay, thank you for followups.

If the problem occurs again, feel free to open a new bug or reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.