Bug 450475 - Error 22 (xen-3.0.3-64.el5_2.1)
Error 22 (xen-3.0.3-64.el5_2.1)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-08 19:49 EDT by Axel Thimm
Modified: 2009-12-14 16:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 05:19:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2008-06-08 19:49:17 EDT
Description of problem:
After the last update the system is not capable of starting the domains:
[2008-06-09 01:37:40 xend 4489] ERROR (xmlrpclib2:184) (22, 'Invalid argument')
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/util/xmlrpclib2.py", line 162, in
_marshaled_dispatch
    response = self._dispatch(method, params)
  File "/usr/lib64/python2.4/SimpleXMLRPCServer.py", line 406, in _dispatch
    return func(*params)
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/XMLRPCServer.py",
line 64, in domain_create
    info = XendDomain.instance().domain_create(config)
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 228, in
domain_create
    dominfo = XendDomainInfo.create(config)
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line
194, in create
    vm.construct()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line
1268, in construct
    handle = uuid.fromString(self.info['uuid']))
Error: (22, 'Invalid argument')

I checked the available versions and it looks like there is a version mismatch
of xen-libs and xen. The latter seems to be missing from rhn in its latest version.

Version-Release number of selected component (if applicable):
3.0.3-64.el5_2.1

How reproducible:
always
Comment 3 Daniel Berrange 2008-06-09 07:28:58 EDT
Please provide your *installed* RPM  versions for

 xen
 xen-libs
 kernel-xen


And the config file for the guest in question from /etc/xen

And the XML config shown by 'virsh dumpxml NAME-OF-GUEST'
Comment 4 Axel Thimm 2008-06-10 23:59:35 EDT
My recent license renewal had reset my channel information in rhn, so I was
getting only base updates. This is why xen and xen-libs managed to diverge in
version. Reactivating vt rectified this.

Maybe xen/xen-libs should have a Conflicts: xen < %{version}, xen > %{version}
to avoid such a setup?

I tried to close as NOTABUG, but bugzilla said:

> Bug Change Denied
> You are not permitted to make this particular change for this bug. Either
because it is a RHEL product and/or you need to be in specific groups to make
this change.
> Please press Back and try again.
Comment 5 Daniel Berrange 2008-06-11 05:19:57 EDT
I don't know how you managed to get a mis-matched pair, because we have a fully
specified dependancy requirement precisely to avoid this problem

Requires: xen-libs = %{version}-%{release}

Note You need to log in before you can comment on or make changes to this bug.