Bug 450489 - wpa-psk with atheros fails
wpa-psk with atheros fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 02:18 EDT by Dhaval Giani
Modified: 2008-11-17 13:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 13:36:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvv (26.12 KB, application/octet-stream)
2008-06-09 02:18 EDT, Dhaval Giani
no flags Details
dmesg with 2.6.25.5-19.fc8 (39.85 KB, text/plain)
2008-06-10 12:50 EDT, Dhaval Giani
no flags Details

  None (edit)
Description Dhaval Giani 2008-06-09 02:18:11 EDT
Description of problem:
Cannot connect to wireless network using WPA-PSK using the atheros card.

Version-Release number of selected component (if applicable):
[root@gondor ~]# uname -r
2.6.25.4-10.fc8
[root@gondor ~]# 


How reproducible:
It has never associated. I have had a couple of hangs, but those are sporadic,
and am not sure if they are related to wireless (most likely they are, because
the system was otherwise quite stable with madiwifi)

Steps to Reproduce:
1. Run wlassistant
2. Fails to associate.
3.
  
Actual results:
Does not associate. Sometimes causes a hang

Expected results:
should connect to the wireless network

Additional info:
attaching lspci -vvv

Let me know what else is needed.
Comment 1 Dhaval Giani 2008-06-09 02:18:11 EDT
Created attachment 308668 [details]
lspci -vvv
Comment 2 Dhaval Giani 2008-06-09 06:54:47 EDT
I forgot to mention, it connects to open networks.
Comment 3 John W. Linville 2008-06-09 10:38:38 EDT
Can you recreate this issue with the current kernels?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=51982

If so, please attach the contents of /var/log/messages after a failed connection
attempt...thanks!
Comment 4 Dhaval Giani 2008-06-10 12:50:28 EDT
Created attachment 308841 [details]
dmesg with 2.6.25.5-19.fc8

has the first connection, without any authentication. One by mistake with WEP,
others with WPA-PSK, and finally attempting to connect without authentication
which also failed.
Comment 5 Dhaval Giani 2008-06-10 12:51:35 EDT
provided dmesg
Comment 6 John W. Linville 2008-10-03 15:44:36 EDT
Please see bug 458972 comment 11...
Comment 7 John W. Linville 2008-10-29 11:18:09 EDT
Disregard comment 6, I think this bug was for a much earlier problem.  Does the problem persist with current kernels?
Comment 8 Dhaval Giani 2008-10-31 09:10:25 EDT
I am currently on vacation, and will be in a position to test in about 10 days time. I will respond back then.
Comment 9 Dhaval Giani 2008-11-17 12:16:55 EST
OK, I just tested it and it works. You can go ahead and close the bug. Thanks a lot!

Note You need to log in before you can comment on or make changes to this bug.