Bug 450497 - sftp service file not installed per default (regression from F7)
sftp service file not installed per default (regression from F7)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 03:45 EDT by Matěj Cepl
Modified: 2018-04-11 08:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-13 05:56:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-06-09 03:45:44 EDT
Description of problem:
In Fedora 7 discovery of sftp services accross the network just worked. In
F{8,9,Rawhide} it doesn't. After pulling all my hair, I found
http://fedoraforum.org/forum/showthread.php?p=935206 and yes

cp /usr/share/doc/avahi-*/sftp-ssh.service /etc/avahi/services/ 

just made it work.

The only mentioning of this regression (it is one, if I every saw one) is:

* Fr Sep 07 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.21-4
- Ship ssh static service file by default, don't ship ssh-sftp by default
- resolves: #269741: split off avahi-ui-tools package
- resolves: #253734: add missing dependency on avahi-glib-devel to avahi-ui-devel

which doesn't explain anything -- two bugs mentioned has nothing to do IMHO with
ssh-sftp service. Is there some particular reason for breaking this functionality?

Version-Release number of selected component (if applicable):
avahi-0.6.22-10.fc9.i386

How reproducible:
100%

Steps to Reproduce:
1.Go to "network:///" in Nautilus
2.
3.
  
Actual results:
No SFTP volumes available.

Expected results:
They should be visible and accessible.
Comment 1 Lennart Poettering 2008-12-13 05:56:11 EST
We decided to remove the sftp service by default because it setting up and configuring file shares is an administrator's job. Previously every single machine would show up with its sftp share in the Nautilus browsing window which made the whole idea of browsing pointless since almost no share registered would actually be useful and especially in larger networks the window wuld be very very crowded and hiding the real file shares.

Note You need to log in before you can comment on or make changes to this bug.