Bug 4505 - NFS mount of /usr is not possible
Summary: NFS mount of /usr is not possible
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-13 12:46 UTC by scheck
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-13 14:16:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description scheck 1999-08-13 12:46:25 UTC
Problem description:
It is not possible to NFS mount /usr exported from another
machine, because /etc/rc.d/init.d/network uses the command
/usr/bin/xargs which is not present at that time.

Quick solution:
Copy /usr/bin/xargs to /bin/xargs.

Proper solution:
Do not use /usr/bin/xargs in /etc/rc.d/init.d/network, but
use $() from bash instead. Generally do not use ANY file
from /usr before mounting NFS volumes and after unmounting
NFS volumes.

Comment 1 Bill Nottingham 1999-08-13 14:16:59 UTC
this is fixed in the initscripts in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.