Bug 450513 - F9 /usr/sbin/sshd permits root login
F9 /usr/sbin/sshd permits root login
Status: CLOSED DUPLICATE of bug 89216
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
All Linux
low Severity urgent
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-06-09 07:26 EDT by Dan O'Brien
Modified: 2008-06-09 07:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-09 07:47:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dan O'Brien 2008-06-09 07:26:10 EDT
Description of problem:

My F9 system got hacked via SSH login of root.  Admittedly root had a weak
password, but previously releases of Fedora/sshd disallowed root login by
default.  Dictionary search allowed root login over SSH even though
/etc/ssh/sshd_config had #PermitRootLogin commented out. I had to explicitly set
PermitRootLogin no to stop root login. This is a changed in default behavior.

I was hacked before I had setup /etc/hosts.allow and /etc/hosts.deny to limit
system exposure to just a few outside systems.

Hacker was from domain ending with .ro.  Created mysql and test logins.  D/l a
file called "Diana.jpg" that was a zip file into /dev/shm.  Contained a ssh-scan
executable that touched every binary on system /bin and /usr/bin attaching some
trojan.  By the time it was caught there were 100 processes of this ssh-scan and
the network light on the computer was clicking away.  Likely d/l all my files
for further scan.  Had to do a full reinstall of F9.

Version-Release number of selected component (if applicable):


How reproducible:

easily.  Ensure #PermitRootLogin is commented out in sshd_config.  Try it.

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Tomas Mraz 2008-06-09 07:47:11 EDT
Root login was never disallowed by default in Fedora/RHEL.
Comment 2 Tomas Mraz 2008-06-09 07:47:27 EDT

*** This bug has been marked as a duplicate of 89216 ***

Note You need to log in before you can comment on or make changes to this bug.