This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450515 - dbus dies right after start on system start
dbus dies right after start on system start
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus (Show other bugs)
5.2
All Linux
low Severity high
: rc
: ---
Assigned To: Matthias Clasen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 07:39 EDT by Klaus Ethgen
Modified: 2015-10-05 07:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:04:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Ethgen 2008-06-09 07:39:21 EDT
Description of problem:
When the messagebus dbus-daemon is started on the system start it immediately 
dies (but give state OK on the boot screen). That leaves to the problem that 
hald cannot be started and so several tools depending on HAL are broken.

Starting the stuff AFTER the boot works well.

Version-Release number of selected component (if applicable):
1.0.0-7

How reproducible:
Boot the system.
  
Actual results:
No dbus-daemon is running (and so no hald also).

Expected results:
It should work.

Additional info:
I tried to debug the stuff. Unfortunately dbus-daemon do log many thinks (= 
NULL) to any logfile. So I cannot see what kind of problems the daemon have. 
Also stracing do not work as with a running strace the daemon runs fine.
Comment 1 David Koppelman 2008-06-15 13:28:27 EDT
I'm experiencing the same problem, also with version 1.0.0-7.el5. Is there a
workaround? Starting dbus and hald after boot does not avoid problems with the
GNOME settings daemon.
Comment 2 Colin.Simpson 2008-06-17 15:18:26 EDT
We've got this one too. Anyone know of a workaround.

Comment 3 David Koppelman 2008-06-17 15:50:51 EDT
This isn't for the feint of heart, but it has been working for me for about a
day and a half.

 1: Rename /bin/dbus-daemon to /bin/dbus-daemon-real
 2: Create a new file named /bin/dbus-daemon with the following contents (be
sure not to indent anything).

   #!/bin/sh
   strace -o /dev/null /bin/dbus-daemon-real $*

 3: Don't forget to set the ownership and permissions appropriately.
 4: Reboot. haldaemon should start normally.
Comment 4 David Koppelman 2008-06-17 15:52:20 EDT
Oh, and this won't work if selinux is being strict.
Comment 5 Colin.Simpson 2008-06-18 14:47:43 EDT
eek, bit of a grim work around. I'm surprised this issue isn't huge, we are now
getting complaints from users who are seeing, CD's and USB's not mounting
automatically.

I'm now wondering is there something different in my (and your) setup that we
are seeing this.

Comment 6 David Koppelman 2008-06-18 14:54:51 EDT
I'm using a Dell Precision 670 with hyperthreading turned off (I believe).
This machine has two CPUs (two chips, one core each).

Wild guess: it has something to do with multiple processors. strace is slowing
things down enough to avoid some kind of race condition.
Comment 7 Colin.Simpson 2008-06-19 09:32:44 EDT
My present work around is putting into /etc/rc.local

/etc/init.d/messagebus condrestart
/etc/init.d/haldaemon restart

Seems to be OK at starting later in the boot process. Not sure why this would
stop a race condition, if that is the problem. 




Comment 8 Colin.Simpson 2008-06-25 05:54:26 EDT
This seems to be related to bug #448014. I downgraded to nss_ldap-253-5.el5 and
this seems to have gone now. I'll relate this bug to it if others see this same
issue.
Comment 9 Colin.Simpson 2009-09-07 09:00:19 EDT
Unless the original poster or the follow ups are seeing this still, I'd suggest this is a duplicate of bug #448014, which when nss_ldap was fixed this problem went away.
Comment 11 RHEL Product and Program Management 2014-03-07 08:35:56 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 12 RHEL Product and Program Management 2014-06-02 09:04:06 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 13 Klaus Ethgen 2015-10-05 07:55:37 EDT
I don't know why I got nagged by that kind of bugs. I also cannot help if you need that long to react on bug reports.

Note You need to log in before you can comment on or make changes to this bug.