Bug 45052 - RFE: Standard installs - leave space for Windows, etc.
RFE: Standard installs - leave space for Windows, etc.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-19 17:10 EDT by Bryce Nesbitt
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 15:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 2001-06-19 17:10:32 EDT
Every time I install RedHat it's the same thing.  I can't use the
"standard" installs because I want to set up a Windows dual boot.

It sure would be nice if anaconda would, during a "standard" install, let
me enter a number of megabytes to leave untouched.  Better yet, have it
make a DOS partition of a particular size.

I think it's common for first time RedHat users to want dual boot
capability.
Comment 1 Brent Fox 2001-06-26 15:45:42 EDT
Actually, I would think that the majority of first time Red Hat users that want
to dual boot already have Windows on there machine.  Thus, their DOS partition
already exists.  
Plus, I think this would really frustrate users that don't have Windows on their
machines at all.  This would basically allocate disk space for an operating
system that they don't have.
Comment 2 Bryce Nesbitt 2001-06-27 01:53:30 EDT
It would be a OPTION, and a simple one at that:

	Disk space to reserve.  To use the entire disk
	for RedHat, enter 0.  To save some space for
	later use, enter a number of megabytes  [ 0         ]

		[ OK]    [SKIP]
Comment 3 Brent Fox 2001-06-27 14:20:54 EDT
You already have the option of partitioning the disk manually with Disk Druid. 
You can reserve all the space you want to.  Automatic partitioning, by
definition, is designed to be automatic.  If you want options, Disk Druid is the
way to go.
Comment 4 Bryce Nesbitt 2001-06-27 23:44:06 EDT
Then you're right back to the complexity of figuring out which partitions to set
up, what size swap to use, if you should creat a boot partition.

Just telling the thing "ignore the partition that's already there" or "leave me
xxxx megabytes to manually partition" would make this worry free.

Note You need to log in before you can comment on or make changes to this bug.