Bug 450540 - broker occasionally leaves lock file in data dir
broker occasionally leaves lock file in data dir
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
low Severity low
: ---
: ---
Assigned To: Alan Conway
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 09:37 EDT by Rafael H. Schloming
Modified: 2014-12-01 18:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 09:43:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael H. Schloming 2008-06-09 09:37:30 EDT
Description of problem:

I ran the java tests in a loop over the weekend. After 200+ runs I had only two
failures. In both cases the test aborted because the broker failed to start due
to a lock file. In both cases the Java logs show the broker exiting normally
prior to this. The two Java test cases are unrelated.

How reproducible:

It took about 100,000 broker starts/stops to hit this issue.

Additional info:

The data dir was on nfs, and the broker was running without the store.
Comment 1 Alan Conway 2008-06-09 10:17:51 EDT
This also happens with a local directory, I got it in 200 iterations of:

while ./qpidd -d -p 8888 --data-dir /tmp/qpidd && ./qpidd -q -p 8888 ; do echo
-n .; done
Comment 2 Alan Conway 2008-06-16 11:08:03 EDT
I've also seen this occasionally in testing where there was no loop, broker was
killed normally. Using flock(3) or lockf(3) on the brokers data dir might be
more reliable than a simple existence test.
Comment 3 Alan Conway 2008-06-16 11:08:54 EDT
NB: in fixing this we should use common code for both the PID file and the lock
file.
Comment 4 Alan Conway 2009-02-17 09:43:09 EST
No longer a problem.

Note You need to log in before you can comment on or make changes to this bug.