Bug 450557 - Gtk-Warning on locating theme engine when executed 'setup'
Gtk-Warning on locating theme engine when executed 'setup'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
9
ppc64 All
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 12:32 EDT by IBM Bug Proxy
Modified: 2014-03-16 23:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 10:27:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing menu polluted with warning messages (95.60 KB, image/jpeg)
2008-06-09 12:33 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 45203 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-06-09 12:32:57 EDT
=Comment: #0=================================================
Indhu Durai <IndhuDurai@in.ibm.com> - 2008-05-29 07:50 EDT
Problem description:
====================
I observed this issue in Fedora-9-GA.ppc64.
When i executed command setup and traversed to keyboard-language settings, i got
the following warnings:

------------------------------------logs----------------------------------------
[root@p520b ~]# setup

(system-config-keyboard:2539): Gtk-WARNING **: Unable to locate theme engine in
module_path: "nodoka",

(system-config-keyboard:2539): Gtk-WARNING **: Unable to locate theme engine in
module_path: "nodoka",
[root@p520b ~]# setup

--------------------------------------------------------------------------------

Machine Information:
====================
uname -a:
---------
Linux p520b.in.ibm.com 2.6.25-14.fc9.ppc64 #1 SMP Thu May 1 05:49:24 EDT 2008
ppc64 ppc64 ppc64 GNU/Linux

Hardware Environment:
---------------------
    Machine type (p650, x235, SF2, etc.):p520
    Cpu type (Power4, Power5, IA-64, etc.):Power5

---------------------------------------------------------------------------------

Is this reproducible? Yes
Describe the steps:
* execute setup command 
* traverse to different settings. I captured this when i entered to keyboad
configuration.
=Comment: #2=================================================
Indhu Durai <IndhuDurai@in.ibm.com> - 2008-06-05 06:50 EDT
Hi,

I am finding this issue in X session. 

Regards,
Indhu D
=Comment: #3=================================================
Edjunior Barbosa Machado <emachado@br.ibm.com> - 2008-06-06 09:41 EDT

screenshot showing menu polluted with warning messages

=Comment: #4=================================================
Edjunior Barbosa Machado <emachado@br.ibm.com> - 2008-06-06 11:24 EDT
It sounds like an issue related to ppc/ppc64 packages. The programs and
libraries are 32 bits but the installed gtk nodoka engine is 64.

[root@p520b ~]# rpm -qa "*gtk*"
gtkglext-libs-1.2.0-6.fc9.ppc
gtk-vnc-python-0.3.4-4.fc9.ppc
xdg-user-dirs-gtk-0.7-1.fc9.ppc
gtkspell-2.0.11-8.fc9.ppc
gtk-vnc-0.3.4-4.fc9.ppc
pygtksourceview-2.2.0-1.fc9.ppc
gtk-sharp2-2.10.3-2.fc9.ppc
gtkhtml3-3.18.1-1.fc9.ppc
gtk2-2.12.9-5.fc9.ppc
GConf2-gtk-2.22.0-1.fc9.ppc
pygtkglext-1.1.0-4.fc9.ppc
usermode-gtk-1.96.1-1.ppc
gtkmm24-2.12.5-1.fc9.ppc
gtksourceview2-2.2.1-1.fc9.ppc
gtkhtml2-2.11.1-3.fc9.ppc
gtk2-engines-2.14.1-1.fc9.ppc
pygtk2-2.12.1-6.fc9.ppc
authconfig-gtk-5.4.2-1.fc9.ppc
gtk2-2.12.9-5.fc9.ppc64
gtk-nodoka-engine-0.7.0-1.fc9.ppc64
pygtk2-libglade-2.12.1-6.fc9.ppc
gnome-python2-gtkhtml2-2.19.1-15.fc9.ppc

After install the 32 bits gtk engine (gtk-nodoka-engine-0.7.0-1.fc9.ppc.rpm),
the keyboard configuration menu seems ok.
Comment 1 IBM Bug Proxy 2008-06-09 12:33:00 EDT
Created attachment 308718 [details]
screenshot showing menu polluted with warning messages
Comment 2 Phil Knirsch 2008-06-10 06:23:39 EDT
Reassigning to setuptool component which contains the setup application.

Read ya, Phil
Comment 3 IBM Bug Proxy 2008-09-04 10:11:05 EDT
Hello Red Hat,

any news regarding this issue?

Thanks
Comment 4 Nalin Dahyabhai 2008-09-04 11:31:11 EDT
It looks like you somehow have a 32-bit version of usermode installed (I only see the 64-bit version in the repository).  It's usermode that wraps the 'setup' program from setuptool in a dialog box if necessary, so any gtk-related errors you're seeing are coming from there.  The 32-bit usermode uses the 32-bit gtk2 package, which in turn needs the 32-bit nodoka engine to make the theme work.

The weird thing about this is that you even have a 32-bit version of usermode install, which suggests that something's not quite right with that Raw Hide tree.  Moving to 'distribution' to get some more eyes on this -- it's possible it was a transient problem in a tree compose, but I can't be sure.
Comment 5 Bill Nottingham 2008-09-04 11:37:34 EDT
ppc64 uses ppc32 as the primary arch.
Comment 6 Bill Nottingham 2008-09-04 11:39:45 EDT
Note that the correct arches of nodoka-theme do appear to be in the tree, so I'm not sure how you ended up missing them.
Comment 7 Nalin Dahyabhai 2008-09-04 14:21:09 EDT
(In reply to comment #5)
> ppc64 uses ppc32 as the primary arch.

So the problem then (er, now) is that there's a 64-bit usermode in there?
Comment 8 Bill Nottingham 2008-09-04 14:24:47 EDT
AFAICT, there isn't a 64-bit usermode, in either the release or updates repository.
Comment 9 IBM Bug Proxy 2008-11-17 00:50:35 EST
(In reply to comment #17)

There where no problems in executing "setup" in F10 Preview. So we can close this bug.
Comment 10 IBM Bug Proxy 2008-11-17 08:10:46 EST
(In reply to comment #18)
> (In reply to comment #17)
>
> There where no problems in executing "setup" in F10 Preview. So we can close
> this bug.
>

Thanks Sachin and Pavan for working on this.
Closing this bug as unreproducible on F10 Preview.
Please feel free to reopen if you see this problem again.

Note You need to log in before you can comment on or make changes to this bug.