This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450576 - kjournald causes sporadic severe slowdown of system
kjournald causes sporadic severe slowdown of system
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
athlon Linux
low Severity low
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 14:23 EDT by stanl
Modified: 2008-06-30 15:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-30 15:13:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stanl 2008-06-09 14:23:42 EDT
Description of problem:  From time to time, kjournald causes the system response
time to slow down significantly.  When it is done, system response time returns.


Version-Release number of selected component (if applicable):
For at least the last two kernels in Fedora 9, the .3 and .4 versions.

How reproducible:  Can't make it happen at will, but it has happened from time
to time since I installed Fedora 9.


Steps to Reproduce:
1.Boot Fedora 9
2.Run for a period of time, with iotop enabled
3.When system is unresponsive, observe iotop, see kjournald running.
  
Actual results:  System will slow to a crawl periodically while kjournald
completes its business.


Expected results:  kjournald runs unobtrusively in background.


Additional info:  Perhaps it is something else affecting kjournald, and
kjournald slowdown is the result.
Comment 1 stanl 2008-06-10 09:44:37 EDT
I've been watching this since I opened the bugzilla.  I notice that whenever it
occurs that Firefox seems to be using lots of IO as well.  And occasinally
PDFlush.  They all seem to want to use 99.99% of the IO capacity at the same
time, and there appears to be thrashing going on, as they swap in and out
quickly.  So my instructions above to reproduce the bug should include using
Firefox.  It seems to require retrieving extra content with Firefox, a search or
a link follow.
Comment 2 Eric Sandeen 2008-06-10 10:09:42 EDT
oh this is probably the firefox fsync issue...

https://bugzilla.mozilla.org/show_bug.cgi?id=421482
Comment 3 Eric Sandeen 2008-06-10 10:28:10 EDT
See also:

https://bugzilla.redhat.com/show_bug.cgi?id=439908

... so hopefully upstream's fix will make it to fedora soon.
Comment 4 stanl 2008-06-10 12:16:05 EDT
Thanks for the update.  I guess this ticket can be relegated to the background now.
Comment 5 Dave Jones 2008-06-30 14:58:01 EDT
firefox updates are now available, which should fix this.
Comment 6 stanl 2008-06-30 15:03:34 EDT
Yes,  I updated as soon as the 3.0 final became available, and indeed it fixed this.

I guess this can be closes somehow.

Note You need to log in before you can comment on or make changes to this bug.