Bug 450580 - find users/groups with blank field
find users/groups with blank field
Status: CLOSED NEXTRELEASE
Product: freeIPA
Classification: Community
Component: ipa-client (Show other bugs)
2.0
All Linux
medium Severity low
: v2 release
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: 431020
  Show dependency treegraph
 
Reported: 2008-06-09 14:29 EDT by Mark Christiansen
Modified: 2015-01-04 18:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-09 13:51:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Christiansen 2008-06-09 14:29:37 EDT
Description of problem:

Not putting anything in the search field under "find users" and "find groups"
should yield all users or all groups.  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
Access web page interface and use find features. I think there should be a way
to list all entities through the search tool
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rob Crittenden 2008-06-11 09:15:40 EDT
We made a conscious decision to not be able to display all
users/groups/services/you name it. We can revisit that in version 2.0.

We want to be able to handle very large organizations (100's of k's of users).
Since we use XML-RPC as our transport protocol we'll either need to implement
some sort of "get next page of stuff" function, return everything at once (which
would likely time out the browser) or do something else that I'm not considering.
Comment 5 Rob Crittenden 2010-09-09 13:51:21 EDT
This will be in v2

Note You need to log in before you can comment on or make changes to this bug.