Bug 450598 - MPI Version Is Broken Due to Build
MPI Version Is Broken Due to Build
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: paraview (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 15:30 EDT by Tyson Whitehead
Modified: 2008-10-23 17:06 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.2.2-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 23:33:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to use FindMPI from latest cmake. (14.81 KB, patch)
2008-06-09 15:30 EDT, Tyson Whitehead
no flags Details | Diff

  None (edit)
Description Tyson Whitehead 2008-06-09 15:30:28 EDT
Description of problem:

The RPM doesn't build the MPI version correctly.

Specifically, the FindMPI package in cmake doesn't not find the MPI libraries
and trying to get around this by just setting CXX=mpic++ does not work (it
doesn't trigger the MPI specific build stuff).

Also, because libraries for the two versions are currently being found through a
file in /etc/ld.so.conf.d/, both versions cannot be installed at the same time.

Version-Release number of selected component (if applicable):

3.2.1-6

How reproducible:

Everytime.

Steps to Reproduce:
1.  yum install paraview-mpi
2.  mpirun --mca btl self,sm -np 2 pvserver-mpi

Actual results:

You will get error messages indicating that the socket is already in use.  That
is because it launched two instances of pvserver-mpi and, as they are not
talking to each other, they both try and grab the server socket.

Expected results:

-bash-3.1$ mpirun --mca btl self,sm -np 2 pvserver-mpi
Listen on port: 11111
Waiting for client...

Additional info:

I've attached a patch that fixes the first of these problems.  It does this by
including the FindMPI package from the latest cmake as a patch and using it in
the MPI build instead of trying to make things work through CXX=mpic++.  It also
corrects the launch command to not use mpirun (proper way with paraview 3).

A possible solution for the second problem would be to re-enable install time
rpaths (using $ORIGIN if it was desired to make the install re-rootable). 
Currently, users should not be allowed to install both MPI and non-MPI versions.
Comment 1 Tyson Whitehead 2008-06-09 15:30:28 EDT
Created attachment 308746 [details]
Patch to use FindMPI from latest cmake.
Comment 2 Orion Poplawski 2008-06-26 16:50:22 EDT
Thanks for the patch, it was very helpful.  I'm building a new version here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=682447

In this version, the -mpi package only ships those binaries that make use of mpi
and uses rpaths so that it can be installed along with the non-mpi version. 
After it builds I'll push to updates-testing.
Comment 3 Orion Poplawski 2008-06-27 13:33:22 EDT
I'm running into some problems compiling due to some changes in the HDF5
library.  It will take a while to get them fixed.
Comment 4 Fedora Update System 2008-07-16 18:50:26 EDT
paraview-3.2.2-1.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-07-19 05:44:06 EDT
paraview-3.2.2-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update paraview'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6555
Comment 6 Fedora Update System 2008-08-12 14:21:56 EDT
paraview-3.2.2-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Michael Schwendt 2008-10-23 17:06:18 EDT
Dunno why this shows up only now, but there's a multiarch broken
dep in the F9 repos now. It seems you changed the package
inter-dependencies, so paraview-mpi.i386 is no longer pulled in:

source rpm: paraview-3.2.1-6.fc9.src.rpm
package: paraview-mpi-3.2.1-6.fc9.i386 from fedora-9-x86_64
  unresolved deps: 
     paraview-data = 0:3.2.1-6.fc9

Note You need to log in before you can comment on or make changes to this bug.