Bug 450620 - libgpsqlbackend.so missing
libgpsqlbackend.so missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pdns (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ruben Kerkhof
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 18:23 EDT by Eric Desgranges
Modified: 2008-06-17 14:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-17 14:11:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Desgranges 2008-06-09 18:23:54 EDT
Pdns installed with PostgreSQL backend.

The logs say:
...................
Unable to load module '/usr/lib/pdns/libgpsqlbackend.so':
/usr/lib/pdns/libgpsqlbackend.so: cannot open shared object file: No such file
or directory
...................

I can't find the file libgpsqlbackend.so indeed.
Comment 1 Eric Desgranges 2008-06-10 03:14:41 EDT
Not only is the file missing but pdns should be looking for libgpgsqlbackend.so
instead (see the extra 'g' inside the name) as it is the case in previous
releases, Fedora 8 for example.

I need a quick fix here, where can I get this file?

MySQL includes this files in the package libs-mysql. Is there such a package for
PostgreSQL?

Comment 2 Ruben Kerkhof 2008-06-10 14:45:50 EDT
Do you have pdns-backend-postgresql installed?
Comment 3 Eric Desgranges 2008-06-10 15:01:57 EDT
Yes, definitively. When I did a
yum install pdns-backend-postgresql

however, I didn't get an extra package as it does with pdns-backend-mysql that
adds libs-mysql.
Comment 4 Ruben Kerkhof 2008-06-11 14:52:05 EDT
It pulls in postgresql-libs:

[root@ruben yum.repos.d]# sudo yum install pdns-backend-postgresql
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for pdns-backend-postgresql to pack into transaction set.
pdns-backend-postgresql-2 100% |=========================| 3.9 kB    00:00     
---> Package pdns-backend-postgresql.x86_64 0:2.9.21-4.el5.centos set to be updated
--> Running transaction check
--> Processing Dependency: libpq.so.4()(64bit) for package: pdns-backend-postgresql
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for postgresql-libs to pack into transaction set.
postgresql-libs-8.1.11-1. 100% |=========================|  16 kB    00:00     
---> Package postgresql-libs.x86_64 0:8.1.11-1.el5_1.1 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 pdns-backend-postgresql  x86_64     2.9.21-4.el5.centos  extras             35 k
Installing for dependencies:
 postgresql-libs         x86_64     8.1.11-1.el5_1.1  updates           195 k
Comment 5 Ruben Kerkhof 2008-06-11 14:56:50 EDT
Actually, it doesn't.
I'll fix the package, in the meantime you can install postgresql-libs.
Comment 6 Eric Desgranges 2008-06-14 17:58:07 EDT
Actually pdns is expecting libgpsqlbackend.so and not libgpgsqlbackend.so. So I
created a link:

ln -s /usr/lib/pdns/libgpgsqlbackend.so /usr/lib/pdns/libgpsqlbackend.so 

But pdns still complains with this error:

----------------------------------------------
pdns[2687]: Guardian is launching an instance
pdns[2687]: This is module gpgsqlbackend.so reporting
pdns[2687]: Fatal error: Trying to launch unknown backend 'gpsql'
pdns[2680]: Our pdns instance exited with code 1
pdns[2680]: Respawning
----------------------------------------------
Comment 7 Eric Desgranges 2008-06-15 03:25:46 EDT
Forget about my last post. That was due to a bad config file. Somehow there must
have been a change of name for the backend and I was perhaps reading an older
documentation. The backend name to use PostgreSQL is 'gpgsql' and not 'gpsql',
so I corrected the config file /etc/pdns/pdns.conf like this:

------------------------
launch=gpsql
gpgsql-host=127.0.0.1
gpgsql-user=*****
gpgsql-dbname=*****
gpgsql-password=*****
------------------------
Comment 8 Ruben Kerkhof 2008-06-15 17:38:16 EDT
Hi Eric

Regarding comment #5, I just installed the backend on Fedora devel, and it pulls
in postgresql-libs:

[ruben@localhost devel]$ sudo yum install pdns-backend-postgresql
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package pdns-backend-postgresql.i386 0:2.9.21-4.fc9 set to be updated
--> Processing Dependency: libpq.so.5 for package: pdns-backend-postgresql
--> Running transaction check
---> Package postgresql-libs.i386 0:8.3.1-1.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 pdns-backend-postgresql  i386       2.9.21-4.fc9     fedora             33 k
Installing for dependencies:
 postgresql-libs         i386       8.3.1-1.fc9      fedora            210 k

The backend is indeed named gpgsql (and has been since at least FC-5)

Is everything working for you now?
Comment 9 Eric Desgranges 2008-06-16 03:19:48 EDT
Hi Ruben,

Yes, it now pulls in the postgresql-libs package. Everything's working fine.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.