Bug 450676 - Add GCC 4.3 as Technology Preview in 5.3
Add GCC 4.3 as Technology Preview in 5.3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc43 (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Jakub Jelinek
TechPreview
: FutureFeature
: 444057 (view as bug list)
Depends On: 439479 459796
Blocks: 391501 RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-06-10 07:40 EDT by Daniel Riek
Modified: 2010-10-22 21:48 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Gnu Compiler Collection 4.4 (GCC4.4) is now included in this release as a Technology Preview. This collection of compilers include C, C++, and Fortran compilers along with support libraries. Note that in the gcc44 packages, the default for gnu89-inline option has been changed to -fgnu89-inline, whereas upstream and future updates of Red Hat Enterprise Linux 5 will default to -fno-gnu89-inline. This is necessary because many headers shipped as part of Red Hat Enterprise Linux 5 expect GNU in-line semantics instead of ISO C99 semantics. These headers have not been adjusted to request GNU in-line semantics through attributes.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:47:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2008-06-10 07:40:14 EDT
GCC 4.3 is the Fedora 9 system compiler and the minimum version to become the
system compiler in the next major release of Red Hat Enterprise Linux.

Therefore - similar to what happened with gcc 4.1 in RHEL 4 - Red Hat is
planning to add it to RHEL 5 as a Technology Preview.

At this point it is unclear, which version of GCC finally will become the system
compiler in the next major version. Red Hat reserves the right to change to a
later version and/or break the ABI for this compiler in a later update to RHEL 5.
Comment 4 Suzanne Yeghiayan 2008-09-11 15:49:45 EDT
*** Bug 444057 has been marked as a duplicate of this bug. ***
Comment 11 Don Domingo 2008-12-02 19:36:38 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Gnu Compiler Collection 4.3 (GCC4.3) is now included in this release as a Technology Preview. This collection of compilers include C, C++, and Fortran 95 compilers along with support libraries.

Note that in the gcc43 packages, the default for gnu89-inline option has been changed to -fgnu89-inline, whereas upstream and future updates of Red Hat Enterprise Linux 5 will default to -fno-gnu89-inline.  This is necessary because many headers shipped as part of Red Hat Enterprise Linux 5 expect GNU in-line semantics instead of ISO C99 semantics. These headers have not been adjusted to request GNU in-line semantics through attributes.
Comment 13 Eric Bachalo 2008-12-08 15:08:25 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,3 +1,7 @@
 Gnu Compiler Collection 4.3 (GCC4.3) is now included in this release as a Technology Preview. This collection of compilers include C, C++, and Fortran 95 compilers along with support libraries.
 
-Note that in the gcc43 packages, the default for gnu89-inline option has been changed to -fgnu89-inline, whereas upstream and future updates of Red Hat Enterprise Linux 5 will default to -fno-gnu89-inline.  This is necessary because many headers shipped as part of Red Hat Enterprise Linux 5 expect GNU in-line semantics instead of ISO C99 semantics. These headers have not been adjusted to request GNU in-line semantics through attributes.+This newer version of gcc will continue to be updated in future RHEL 5 releases until it is synchronized with the base gcc released in RHEL 6.  All issues with gcc43 will be accepted and worked.  ABI compatibility issues are unknown and there are no guarantees of compatibility between this and previous or future gcc versions at this time.
+
+Note that in the gcc43 packages, the default for gnu89-inline option has been changed to -fgnu89-inline, whereas upstream and future updates of Red Hat Enterprise Linux 5 will default to -fno-gnu89-inline.  This is necessary because many headers shipped as part of Red Hat Enterprise Linux 5 expect GNU in-line semantics instead of ISO C99 semantics. These headers have not been adjusted to request GNU in-line semantics through attributes.
+
+There are also known ABI changes in libgfortran between gcc 4.1.x and 4.3.x, predominantly in the decimal floating point calling conventions.
Comment 14 Ryan Lerch 2008-12-08 20:59:55 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,7 +1,3 @@
 Gnu Compiler Collection 4.3 (GCC4.3) is now included in this release as a Technology Preview. This collection of compilers include C, C++, and Fortran 95 compilers along with support libraries.
 
-This newer version of gcc will continue to be updated in future RHEL 5 releases until it is synchronized with the base gcc released in RHEL 6.  All issues with gcc43 will be accepted and worked.  ABI compatibility issues are unknown and there are no guarantees of compatibility between this and previous or future gcc versions at this time.
+Note that in the gcc43 packages, the default for gnu89-inline option has been changed to -fgnu89-inline, whereas upstream and future updates of Red Hat Enterprise Linux 5 will default to -fno-gnu89-inline.  This is necessary because many headers shipped as part of Red Hat Enterprise Linux 5 expect GNU in-line semantics instead of ISO C99 semantics. These headers have not been adjusted to request GNU in-line semantics through attributes.-
-Note that in the gcc43 packages, the default for gnu89-inline option has been changed to -fgnu89-inline, whereas upstream and future updates of Red Hat Enterprise Linux 5 will default to -fno-gnu89-inline.  This is necessary because many headers shipped as part of Red Hat Enterprise Linux 5 expect GNU in-line semantics instead of ISO C99 semantics. These headers have not been adjusted to request GNU in-line semantics through attributes.
-
-There are also known ABI changes in libgfortran between gcc 4.1.x and 4.3.x, predominantly in the decimal floating point calling conventions.
Comment 15 Issue Tracker 2008-12-10 21:27:48 EST
Hi Ryan,

I noticed the ABI comment got dropped; if it was a true statement, could
it be included? These sort of things are hard to track down, so anywhere
it's published is helpful from the support perspective.

Thanks,

Andrew


This event sent from IssueTracker by ahecox 
 issue 195875
Comment 16 Issue Tracker 2008-12-10 21:32:30 EST
after some more review, the other part of Eric's initial version would be
useful as well. Again, that sort of stuff isn't documented much elsewhere
(at least in @redhat.com), so putting it somewhere searchable is very
helpful.


This event sent from IssueTracker by ahecox 
 issue 195875
Comment 18 errata-xmlrpc 2009-01-20 15:47:05 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0077.html
Comment 23 Eric Bachalo 2009-05-15 15:30:11 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,3 +1,3 @@
-Gnu Compiler Collection 4.3 (GCC4.3) is now included in this release as a Technology Preview. This collection of compilers include C, C++, and Fortran 95 compilers along with support libraries.
+Gnu Compiler Collection 4.4 (GCC4.4) is now included in this release as a Technology Preview. This collection of compilers include C, C++, and Fortran 95 compilers along with support libraries.
 
-Note that in the gcc43 packages, the default for gnu89-inline option has been changed to -fgnu89-inline, whereas upstream and future updates of Red Hat Enterprise Linux 5 will default to -fno-gnu89-inline.  This is necessary because many headers shipped as part of Red Hat Enterprise Linux 5 expect GNU in-line semantics instead of ISO C99 semantics. These headers have not been adjusted to request GNU in-line semantics through attributes.+Note that in the gcc44 packages, the default for gnu89-inline option has been changed to -fgnu89-inline, whereas upstream and future updates of Red Hat Enterprise Linux 5 will default to -fno-gnu89-inline.  This is necessary because many headers shipped as part of Red Hat Enterprise Linux 5 expect GNU in-line semantics instead of ISO C99 semantics. These headers have not been adjusted to request GNU in-line semantics through attributes.
Comment 25 Eric Bachalo 2009-05-15 15:49:26 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,3 +1,3 @@
-Gnu Compiler Collection 4.4 (GCC4.4) is now included in this release as a Technology Preview. This collection of compilers include C, C++, and Fortran 95 compilers along with support libraries.
+Gnu Compiler Collection 4.4 (GCC4.4) is now included in this release as a Technology Preview. This collection of compilers include C, C++, and Fortran compilers along with support libraries.
 
 Note that in the gcc44 packages, the default for gnu89-inline option has been changed to -fgnu89-inline, whereas upstream and future updates of Red Hat Enterprise Linux 5 will default to -fno-gnu89-inline.  This is necessary because many headers shipped as part of Red Hat Enterprise Linux 5 expect GNU in-line semantics instead of ISO C99 semantics. These headers have not been adjusted to request GNU in-line semantics through attributes.

Note You need to log in before you can comment on or make changes to this bug.