Bug 450678 - F9 net installer and F9 CD1 installer hangs on Advent laptop
F9 net installer and F9 CD1 installer hangs on Advent laptop
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 08:05 EDT by Keith Roberts
Modified: 2009-04-28 15:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 15:43:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Initial messages from iso-linux (86.72 KB, image/jpeg)
2008-06-28 12:39 EDT, Keith Roberts
no flags Details
Error messages from vmlinuz after probing EDD (79.69 KB, image/jpeg)
2008-06-28 12:45 EDT, Keith Roberts
no flags Details
Advent 6415 video BIOS details (64.00 KB, application/octet-stream)
2008-07-03 05:19 EDT, Keith Roberts
no flags Details

  None (edit)
Description Keith Roberts 2008-06-10 08:05:21 EDT
Description of problem:

The F9 installer disks hang on my Advent 6415 laptop (PC133 512MB) intel Pentium
1.2Ghz. Specs at http://www.uktsupport.co.uk/advent/laptop/6415.htm

This applies both to the Fedora-9-i386-netinst.iso, and the Fedora-9-i386-disc1.iso

(I have checked the Fedora-9-i386-netinst.iso on another newer machine with an
Asrock DDR board, at it works as expected.)

When I try and boot from the Fedora-9-i386-netinst.iso CD-R on my laptop, I get
the following messages:
 
 Welcome to Fedora 9! [the installer splash screen]
 
 I then click on either:
 
 Install or upgrade an existing system
 [or]
 Install or upgrade an existing system (text mode)
 
 [both give me the same following error]
 
 Loading vmlinuz........................................... ..............
 Loading initrd.img........................................ .................
 ...............ready.
 Probing EDD (edd=off to disable)... ok
 vmlinuz: attempted DOS system call
 boot:
 
 If I hit return now, the machine goes back to the 'Welcome to Fedora 9!' splash
screen.
 
I have tried entering the edd=off kernel parameter by pressing TAB key at the
splash screen. This still does not work. The installer still hangs without
displaying the edd=off message, like this:

 Loading vmlinuz........................................... ..............
 Loading initrd.img........................................ .................
 ...............ready.
 vmlinuz: attempted DOS system call
 boot:

Obviously the F8 net-installer works OK on my laptop.

How reproducible:
 All the time

Steps to Reproduce:

Try booting any of the F9 installers from CD/DVD on an older laptop, circa 2000/1.

Actual results:
 The installer hangs without starting to decompress the linux kernel image.

Expected results:
 I expect the installation to work correctly with either the net-install disk,
or CD disk 1 of F9.

Additional info:
 I know my laptop is not latest technology, but I would not consider it to be
obsolete yet either :) There must be plenty of other people that want to install
F9 on older laptops such as my Advent 6415.
Comment 1 Chuck Ebbert 2008-06-11 17:42:57 EDT
When it says 'boot:' just type linux (or linux0) and press enter.
Comment 2 Chuck Ebbert 2008-06-11 17:54:01 EDT
In message: http://lkml.org/lkml/2008/6/10/459

 I have put in syslinux 3.70-pre16 code to print the source of this 
 message.  You may want to try to grab isolinux from this release and 
 update your CD image to get some useful debugging info out of this.

	-hpa
Comment 3 Keith Roberts 2008-06-11 19:49:28 EDT
I tried

boot: linux
and 
boot: linux0

neither of those worked. I also tried noprobe. That did not work either :(

Here is the patch from H. Peter Anvin:

ftp://ftp.kernel.org/pub/linux/utils/boot/syslinux/Testing/syslinux-3.70-pre16.tar.bz2
Comment 4 Chuck Ebbert 2008-06-12 01:17:57 EDT
Peter, can we get that patch in rawhide? 

Keith, can you confirm that the current rawhide install CD fails the same way?
Comment 5 Keith Roberts 2008-06-12 04:31:00 EDT
Chuck - Do you have a link to a current rawhide net-installer iso I can download
and burn to CD and test this out?

Or would the boot.iso from here be suitable to burn and test on my lappy?

http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/images/boot.iso

Also, what is the mkisofs command that was used to burn the current
Fedora-9-i386-netinst.iso I'm having problems with please?

Comment 6 Keith Roberts 2008-06-12 05:09:49 EDT
I have downloaded and burnt the boot.iso from the above link.

boot.iso 	11-Jun-2008 04:58 	116M	

Still get exactly the same problems, even trying the different kernel
parameters, and boot: linux

BTW - could not find any SHA1SUM file to verify the integrity of the downloaded
iso file.
Comment 7 H. Peter Anvin 2008-06-12 20:57:19 EDT
What is the message you get, though?
Comment 8 H. Peter Anvin 2008-06-12 21:06:04 EDT
Sorry, I guess this is not with the new isolinux yet.

As far as Syslinux 3.70 is concerned, it should be close to being finalized; I
expect perhaps a few more prereleases and 3.70 final before the end of June.
Comment 9 Keith Roberts 2008-06-13 01:07:33 EDT
I have the same messages with the rawhide boot.iso as downloaded in comment #6.
I have not attempted to try and hack the new Syslinux 3.70 patch into the
boot.iso yet. Still need to read up on mkisofs to create the iso with.

I was hoping the Fedora team would be able to release a patched boot.iso soon
for me to try out on my Advent laptop :)
Comment 10 Keith Roberts 2008-06-13 07:02:24 EDT
I seem to be getting nowhere fast trying to patch up a boot.iso with the
Syslinux 3.70 patch.

If someone would like to create a new pre-release boot.iso image with the
syslinux-debug.bin file and let me have a download link for it, then I will burn
it to CD and try and boot my laptop from it, to see what messages I can get.

Keith :)
Comment 11 H. Peter Anvin 2008-06-26 20:56:18 EDT
Any news on this?

I plan to release Syslinux 3.70 final this weekend unless I hear anyone scream.
Comment 12 H. Peter Anvin 2008-06-26 21:56:30 EDT
FWIW, I hacked up a boot iso with Syslinux 3.70-pre26 on it:

http://www.zytor.com/~hpa/fedora/boot-fc9-3.70-pre26.iso

[still uploading - give it a few minutes]

Found a bad bug in isolinux in the process...
Comment 13 Keith Roberts 2008-06-27 17:14:59 EDT
Thanks for doing that Peter. I will d/l it and burn it to CD-ROM ASAP and see 
what error messages I get when booting my advent 6415.

Comment 14 Keith Roberts 2008-06-28 12:39:59 EDT
Created attachment 310506 [details]
Initial messages from iso-linux

These are the messages I get when the CD-ROM is first starting. Is it possible
to put a configuration directive in the isolinux.cfg file to delay this screen
from clearing so quickly?
Comment 15 Keith Roberts 2008-06-28 12:45:42 EDT
Created attachment 310507 [details]
Error messages from vmlinuz after probing EDD

The message is:

Probing EDD (edd=off to disable)... ok
vmlinuz: attempted DOS system call INT 2F 4F91 C00016E4
boot:
Comment 16 H. Peter Anvin 2008-07-01 01:14:32 EDT
I kind of suspected that.

You have a VESA BIOS which tries to call into DOS!
(The address C000xxxx tells you it comes from inside the video ROM...)

INT 2F AX=4F91h is not documented in Ralf Brown's interrupt list, or in
"Undocumented DOS", so I really have no idea what it's actually trying to do.



Comment 17 H. Peter Anvin 2008-07-01 01:29:57 EDT
I have made a Syslinux 3.71-pre1 release which issues an IRET for INT 2Fh;
please try this iso:

http://www.zytor.com/~hpa/fedora/boot-fc9-3.71-pre1.iso
Comment 18 Keith Roberts 2008-07-01 04:41:01 EDT
I have tried 3.71-pre1.iso and I get the initial messages from syslinux, then 
the same message:

Probing EDD (edd=off to disable)... ok
vmlinuz: attempted DOS system call
boot:

but without the following debug details:
INT 2F 4F91 C00016E4
Comment 19 Keith Roberts 2008-07-01 06:15:55 EDT
WRT comment #16. The CD installer for F8 does not have this problem on my 
Advent, and works fine. Is there some way to kdiff3 the code for the syslinux 
that comes with F8, and the latest syslinux with F9 to possibly identify what 
is causing this problem?
Comment 20 H. Peter Anvin 2008-07-01 20:51:30 EDT
My apologies, I uploaded the wrong image.  Now updated, please try again.
Comment 21 Keith Roberts 2008-07-02 09:22:37 EDT
No problem Peter. I have downloaded the iso again. The initial message says,

ISOLINUX 3.60 0x4761aa6a (C) 1994-2007

Is this a previous version you are working on to upgrade?

I still get the same error as in comment #18
 
Comment 22 H. Peter Anvin 2008-07-02 16:17:13 EDT
No, there is something more fundamentally wrong here.

Please verify the md5sum:
3244eb870f8d69d3a72f7655c4edef0d  public_html/fedora/boot-3.71-pre1.iso

It should say:
ISOLINUX 3.71 3.71-pre1  Copyright (C) 1994-2008 H. Peter Anvin
Comment 23 H. Peter Anvin 2008-07-02 16:18:19 EDT
Err.  I uploaded it with the wrong *name* this time.  Fixed.
Comment 24 H. Peter Anvin 2008-07-02 16:19:06 EDT
Just to clarify: the file with the above URL:

http://www.zytor.com/~hpa/fedora/boot-fc9-3.71-pre1.iso

... is now the right one.  Please do verify the md5sum,
3244eb870f8d69d3a72f7655c4edef0d.
Comment 25 H. Peter Anvin 2008-07-02 17:10:39 EDT
Also, if you could run the following perl script:

http://www.zytor.com/~hpa/fedora/vgabios.pl

... as root, and attach the output to this ticket:

perl vgabios.pl > vgabios.bin

... it might help understand what on Earth it is trying to do.
Comment 26 Keith Roberts 2008-07-03 05:16:59 EDT
It's working now Peter. Both in text and graphical mode installation. It just 
displays the message:

Probing EDD (edd=off to disable)... ok

and then continues with the installation as expected. (I had to hit the 
Pause/Break key to see the message without it wizzing by.)

And it does not display the error message:

vmlinuz: attempted DOS system call

I've got as far as the first screen:

"Welcome to Fedora for i386

Disc Found

To begin testing the media before installation press OK.

Choose Skip to skip the media test and start the installation."

I take it the rest of the installation will go as expected now, if I continued 
with it? 
Comment 27 Keith Roberts 2008-07-03 05:19:32 EDT
Created attachment 310902 [details]
Advent 6415 video BIOS details
Comment 28 H. Peter Anvin 2008-07-07 15:12:14 EDT
From the looks of it, it's a hook to expand their VESA functionality via a TSR,
but instead of chaining INT 10h, they expect the TSR to chain the DOS interrupt
INT 2Fh.  They seem to have some fairly lame installation check, which
incorrectly triggers.

Either way, the workaround will be in Syslinux 3.71.
Comment 29 Keith Roberts 2008-07-08 05:03:19 EDT
Thankyou for sorting this one out Peter. According to my Advanced MS-DOS 
programming book, by Peter Duncan, MS press, int 2FH is:

Int 2FH
Multiplex interrupt.
Provides a general-purpose avenue of communication with another process or 
with MS-DOS extensions, such as the print spooler, ASSIGN, SHARE and APPEND.

I did google for 'INT 2FH' and got 22,400 results.

This is quiet interesting:

http://members.tripod.com/~Vitaly_Filatov/ng/asm/asm_011.16.html

I'm looking forward to testing out the next release of Fedora 9 using your 
latest patched version of Syslinux 3.71
Comment 30 H. Peter Anvin 2008-07-08 16:33:32 EDT
I'm quite aware, thank you, of the meaning of the MS-DOS multiplex interrupt. 
It is still pretty dimwitted of the VESA BIOS to blindly call an MS-DOS interrupt!
Comment 31 H. Peter Anvin 2008-07-08 16:34:38 EDT
Perhaps you could try out:

http://www.zytor.com/~hpa/fedora/boot-fc9-3.71-pre6.iso

The logic is a little different than in the -pre1 version.
Comment 32 Keith Roberts 2008-07-09 10:23:16 EDT
Hi Peter. No offence intended! I posted comment #29 in response to comment #16
As you're probably aware though, Googling for 'AX=4F91h' returned zilch 
matches.

Why would a VESA BIOS want to call a Multiplex interrupt? I can understand it 
calling INT 10 to access the ROM BIOS video routines to get/set something, but 
multiplexer?? :(

Anyway, I have tried the latest fc9-pre6.iso

That works in graphical modes 1 & 2, and text modes 1 & 2 :)
Comment 33 H. Peter Anvin 2008-07-09 21:23:51 EDT
The answer is of course that someone who knew how to write DOS TSRs got let to
write a BIOS.  Some VESA BIOSes are minimal feature, and have extended features
via a DOS TSR.  This is normally done by registering a pointer via INT 10h or
hooking INT 10h, but someone thought it was more "clever" to hook INT 2Fh...
Comment 34 LiYijun 2008-07-26 08:39:50 EDT
(In reply to comment #0)
> Description of problem:
> The F9 installer disks hang on my Advent 6415 laptop (PC133 512MB) intel 
Pentium
> 1.2Ghz. Specs at http://www.uktsupport.co.uk/advent/laptop/6415.htm
> This applies both to the Fedora-9-i386-netinst.iso, and the Fedora-9-i386-
disc1.iso
> (I have checked the Fedora-9-i386-netinst.iso on another newer machine with an
> Asrock DDR board, at it works as expected.)
> When I try and boot from the Fedora-9-i386-netinst.iso CD-R on my laptop, I 
get
> the following messages:
>  
>  Welcome to Fedora 9! [the installer splash screen]
>  
>  I then click on either:
>  
>  Install or upgrade an existing system
>  [or]
>  Install or upgrade an existing system (text mode)
>  
>  [both give me the same following error]
>  
>  Loading vmlinuz........................................... ..............
>  Loading initrd.img........................................ .................
>  ...............ready.
>  Probing EDD (edd=off to disable)... ok
>  vmlinuz: attempted DOS system call
>  boot:
>  
>  If I hit return now, the machine goes back to the 'Welcome to Fedora 9!' 
splash
> screen.
>  
> I have tried entering the edd=off kernel parameter by pressing TAB key at the
> splash screen. This still does not work. The installer still hangs without
> displaying the edd=off message, like this:
>  Loading vmlinuz........................................... ..............
>  Loading initrd.img........................................ .................
>  ...............ready.
>  vmlinuz: attempted DOS system call
>  boot:
> Obviously the F8 net-installer works OK on my laptop.
> How reproducible:
>  All the time
> Steps to Reproduce:
> Try booting any of the F9 installers from CD/DVD on an older laptop, circa 
2000/1.
> Actual results:
>  The installer hangs without starting to decompress the linux kernel image.
> Expected results:
>  I expect the installation to work correctly with either the net-install disk,
> or CD disk 1 of F9.
> Additional info:
>  I know my laptop is not latest technology, but I would not consider it to be
> obsolete yet either :) There must be plenty of other people that want to 
install
> F9 on older laptops such as my Advent 6415.

Comment 35 LiYijun 2008-07-27 01:49:38 EDT
Ha, I installed am successful. 
Starts, also has like on problem. 
Afterward was solves like this: 
I am have not engraved record the disc which installs with FTP to install! 
first, first preassemble windowsxp, certainly winpe may also, then, 
move in openSuse openSUSE11_0_LOCAL.exe(http://xianexs.mail.qq.com/cgi-
bin/downloadfilepart/svrid251/openSUSE11_0_LOCAL.rar?
svrid=251&fid=715f6b903f7023cfd25dfa0009e1b95de70447ca7d673bf6&&txf_fid=&&txf_si
d=)(Raises the code fetch is: d529188a), 
by now, the Partition  C produced openSUSE the folder, then, withdraws inside 
Fedora9.ISO images \ pxeboot table of contents vmlinuz and initrd.img these two 

documents to Partition  C openSUSE folder, revises Partition  C table of 
contents the menu.lst document, after the revision content is as follows: 

hiddenmenu 
timeout 0 
title openSUSE 11.0 installer (LOCAL) 

kernel /openSUSE/vmlinuz
initrd /openSUSE/initrd.img

Finally, in a Boot.ini Riga line: C:\grldr = " Install Fedora9 System '' 

After completing, restarted the computer, the guidance installment may! Done! 
Comment 36 Keith Roberts 2008-08-31 17:00:39 EDT
Is there an ETA for when this patched isolinux will make it into the iso's on the download servers please. I would like to install F9 onto my laptop before F8 has passed it's lifetime of security updates :)

Obviously, as the isolinux is used only once at installation time, it will not appear as a regular system update.

Could someone please post a comment on this bug report when the patched isolinux is generally available for download, with the link as well?
TIA

Keith Roberts
Comment 37 Keith Roberts 2008-11-27 09:44:24 EST
Moved it to rawhide.
Comment 38 gregor 2009-01-03 10:31:01 EST
hi,

i have the same problem on a laptop (geritec 1230i).
the image from H. Peter Anvin (http://www.zytor.com/~hpa/fedora/boot-fc9-3.71-pre6.iso) boots and the installation starts but after creating the partions the installation-routine didn't find the repo to rawhide
can anybody create an image to a non rawhide image ?
sry for my bad english but i didn't understand the guide from LiYijun can anybody translate it to english :-) or german?

greetings from austria
gregor
Comment 39 Keith Roberts 2009-01-04 12:56:56 EST
You need to remaster your boot CD or DVD iso image.

I updated the F10 DVD using the image from H. Peter Anvin
(http://www.zytor.com/~hpa/fedora/boot-fc9-3.71-pre6.iso)

Using the Fedora 10 DVD as an example, the steps are:

mount your Fedora DVD iso with:

[root@karsites ~]# mount -v \ Fedora-10-i386-DVD.iso /downloads/linux/fedora/10/mount -o loop

cd to the 'mount' directory which contains the mounted iso image and copy everything in it to a new directory. 

cd to the new directory you copied the files to. This is now your iso image master file tree that you will use to rebuild a new iso file.

You will now need to overwrite the file in /isolinux/isolinux.bin with HPA's
boot-fc9.3.71-pre6.iso .

To do that copy Peter's working boot-fc9.3.71-pre6.iso to the file called isolinux.bin in your new image master file tree.

That's the file that causes your machine to hang. Just change that file only.

Then run the following shell script:

#! /bin/bash

# create the iso image file
genisoimage -r -o new-Fedora-10-DVD.iso \
 -V "Fedora 10 i386 DVD" \
 -b isolinux/isolinux.bin \
 -c isolinux/boot.cat \
 -no-emul-boot \
 -boot-load-size 4 \
 -boot-info-table \
 /downloads/linux/fedora/10/new-fedora-10-DVD-iso

This will create a new version of F10 with the working isolinux.bin file from Peter.

For testing purposes, you might want to create the .iso file first without adding  the contents of (DVD) Packages subdir. That will tell you if you have re-created the F10 iso correctly.

You can then add the contents of the Packages sub-dir, and remaster the complete F10 DVD.

HTH

Keith
Comment 40 Keith Roberts 2009-01-05 00:57:58 EST
(In reply to comment #39)

X You will now need to overwrite the file in /isolinux/isolinux.bin with HPA's
X boot-fc9.3.71-pre6.iso .
X 
X To do that copy Peter's working boot-fc9.3.71-pre6.iso to the file called
X isolinux.bin in your new image master file tree.

Sorry. What I should have said was:

You need to mount the bootable image boot-fc9.71-pre6.iso with something like:

mount -v \ boot-fc9-3.71-pre6.iso /downloads/linux/isolinux-boot-test/iso-mount -o loop

cd to the /iso-mount/isolinux directory. Copy the working isolinux.bin file (isolinux.bin  13185 Jul  8  2008) from this directory, to your new Fedora 10 image master file tree. Overwite the old version of /isolinux/isolinux.bin (isolinux.bin  12331 Nov  20  00:53) with HPA's newer version.

Then continue with the instructions above.
Comment 41 gregor 2009-01-05 11:22:20 EST
hi,

thank you for the instruction, it works perfect.
and also thanks to hpa for the great work :-)

gregor
Comment 42 Keith Roberts 2009-01-05 15:37:53 EST
Pleased to hear you got it going now Gregor.

Looking inside the /isolinux/isolinux.bin file on the F10 distro, the date is:

ISOLINUX 3.61 2008-02-03

It would be handy if this was updated to the latest version in the Fedora image tree, to implement HPA's patches :)
Comment 43 Jeremy Katz 2009-04-28 15:43:17 EDT
F11 has current syslinux in it

Note You need to log in before you can comment on or make changes to this bug.