Bug 450687 - bdb_perl needs to be removed from scdb and tsdb Requires and from iso
bdb_perl needs to be removed from scdb and tsdb Requires and from iso
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
520
All Linux
low Severity low
: ---
: ---
Assigned To: Milan Zázrivec
Steve Salevan
:
Depends On:
Blocks: 446877
  Show dependency treegraph
 
Reported: 2008-06-10 09:21 EDT by Milan Zázrivec
Modified: 2008-11-05 13:40 EST (History)
2 users (show)

See Also:
Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 13:40:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zázrivec 2008-06-10 09:21:32 EDT
Description of problem:
tsdb and scdb packages depend on package bdb_perl (bdb_perl provides 
NOCpulse::BDB and NOCpulse::BDB2 perl modules), but neither of the two
packages actually needs it.

scdb and tsdb source directories contain two perl scripts (fetch_state_changes
and fetch_time_series) that use NOCpulse:BDB, none of these two scripts are
being packaged though.

bdb_perl package needs to be removed from satellite 5.2 iso and tsdb + scdb
package Requires.

Version-Release number of selected component (if applicable):
tsdb-1.27.13-18, scdb-1.15.3-11, bdb_perl-2.9.3-4

How reproducible:
Always

Steps to reproduce:
1. Mount satellite 5.2 ISO and cd into it
2. $ find . -name "bdb_perl*"
3. $ find . -name "tsdb-*"|xargs rpm -qp --requires|grep 'NOCpulse::BDB'
4. $ find . -name "scdb-*"|xargs rpm -qp --requires|grep 'NOCpulse::BDB'
Comment 1 Jan Pazdziora 2008-06-10 09:27:23 EDT
Removed bdb_perl from comps.

Checking in comps-rhel4-rhnsat52.xml;
/cvs/devel/comps/comps-rhel4-rhnsat52.xml,v  <--  comps-rhel4-rhnsat52.xml
new revision: 1.14; previous revision: 1.13
done

Checking in comps-rhel5-rhnsat52.xml;
/cvs/devel/comps/comps-rhel5-rhnsat52.xml,v  <--  comps-rhel5-rhnsat52.xml
new revision: 1.6; previous revision: 1.5
done
Comment 2 Jan Pazdziora 2008-06-10 09:39:49 EDT
I've also untagged builds from 5.2 tags, and blocked bdb_perl package from
satellite-4E-5.2 and satellite-5E-5.2.
Comment 3 Milan Zázrivec 2008-06-10 10:02:22 EDT
SVN revisions: 173784, 173787
Comment 4 Milan Zázrivec 2008-06-17 09:29:28 EDT
Also, rhns-proxy-monitoring does not depend on bdb_perl anymore.

SVN revision: 174129
Comment 5 Brad Buckingham 2008-08-13 12:54:41 EDT
Mass move to ON_QA.
Comment 6 Steve Salevan 2008-08-18 14:29:22 EDT
Ran the following commands (which ran against all candidate trees):

# find /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL* -name "bdb_perl*" 2> /dev/null
# find /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL* -name "tsdb-*" 2> /dev/null | xargs rpm -qp --requires | grep 'NOCpulse::BDB'
# find /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL* -name "scdb-*" 2> /dev/null | xargs rpm -qp --requires | grep 'NOCpulse::BDB'

and received no output.  This looks like the expected behavior, so I'm moving this bug to VERIFIED.
Comment 7 wes hayutin 2008-10-21 12:15:23 EDT
release pending
Comment 8 Brandon Perkins 2008-11-05 13:40:33 EST
5.2.0 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.