This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450702 - After update to NetworkManager 0.6.6-2, WiFi no longer works
After update to NetworkManager 0.6.6-2, WiFi no longer works
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 11:12 EDT by Steevithak
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.6.6-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-14 00:18:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
excerpt 1 from /var/log/messages (3.91 KB, text/plain)
2008-06-13 08:03 EDT, Damian Steward
no flags Details
excerpt 2 from /var/log/messages (5.56 KB, text/plain)
2008-06-13 08:10 EDT, Damian Steward
no flags Details

  None (edit)
Description Steevithak 2008-06-10 11:12:25 EDT
Description of problem:

I did a "yum update" last night and got NetworkManager 0.6.6-2 on my Fedora 7
laptop. After rebooting, The laptop won't connect to WiFi networks. The
NetworkManager icon spins for a moment and then shows the red/white X icon. If I
click the NetworkManager icon, it does list the available networks but it won't
connect to any of them. If I turn off NetworkManager and manually configure
networking from command line it still works.


Version-Release number of selected component (if applicable):
NetworkManager-0.6.6-2.fc7


How reproducible:
Always


Steps to Reproduce:
1. Update Fedora 7 to NetworkManager 0.6.6-2
2. Reboot
3. Enjoy being offline
  
Actual results:
Laptop can no longer connect to any WiFi network


Expected results:
Laptop should connect to WiFi normally

Additional info:
All previous version of NetworkManager worked fine on this Dell Inspiron 8600
laptop with Intel wifi card. Appears to be a new bug in NetworkManager or
something that broke in the latest RPM file. I'd revert but I'm not sure how to
tell yum I want to downgrade to the last version of NetworkManager...
Comment 1 Steevithak 2008-06-10 11:48:38 EDT
After experimenting a little more, I've noticed that if I leave the mouse
pointer parked over the NetworkManager icon so I can see the status messages,
the last one shown is "Waiting for Network Key for the wireless network '(null)'..."

Assuming this messages is accurate, maybe something broke NetworkManagers
ability to retrieve the login info from the keyring program? I am still prompted
to unlock the keyring when the laptop boots and other programs that use the
keyring continue to work fine. No passwords or logins have been changed either
on my laptop or the WiFi network. 
Comment 2 Helge Deller 2008-06-10 17:16:02 EDT
I can confirm this problem.
Reverting back to NetworkManager-0.6.6-1.fc7.i386.rpm solves it.
Problem occurs both with an ath5k and prism54 softmac pccard NIC, which both 
work with NetworkManager-0.6.6-1.fc7.i386.rpm.

Comment 3 Ilya Ryabinkin 2008-06-12 02:44:28 EDT
I confirm the bug.

Not only wireless networking has problems but wired network works strange. When
I've restarted computer and log in Gnome, nm-applet icon shows that no
connection available although everything is working. Restarting network manager
creates infinitely spinning two green points in applet (creating connection as I
understand). 
Comment 4 Damian Steward 2008-06-13 08:03:01 EDT
Created attachment 309197 [details]
excerpt 1 from /var/log/messages

This is what I get when I start my laptop, which attempts to connect to my WLAN
connection.
Comment 5 Damian Steward 2008-06-13 08:10:52 EDT
Created attachment 309198 [details]
excerpt 2 from /var/log/messages

These are the log messages when I 'enable wirelss' from the NM panel icon and
attempt to connect to the WLAN connection.
Subsequently, the connection is never made, instead the two green dots stay
lighted and the connection graphic continues animating uselessly for quite some
time until manually stopped.
Comment 6 Damian Steward 2008-06-13 08:13:32 EDT
Comment on attachment 309197 [details]
excerpt 1 from /var/log/messages

The messages when my laptop starts up. No connection is attempted, and the 'no
connection' icon is displayed
Comment 7 Dan Williams 2008-06-13 10:35:11 EDT
If people could test out
http://koji.fedoraproject.org/koji/taskinfo?taskID=660749 ASAP and tell me if it
works for them I'll push that to F7 updates.  It reverts to the sources used in
0.6.6-1.
Comment 8 Fedora Update System 2008-06-13 12:14:56 EDT
NetworkManager-0.6.6-3.fc7 has been submitted as an update for Fedora 7
Comment 9 Justin Payne 2008-06-13 23:05:20 EDT
Dan,

  Just got hit with this tonight. The new packages on koji fixed the problem.

Thanks
Comment 10 Fedora Update System 2008-06-14 00:18:55 EDT
NetworkManager-0.6.6-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Damian Steward 2008-06-14 00:43:02 EDT
Thanks a bunch, Dan!
Your 0.6.6-3.fc7 rpms work fine for me too. :)
Comment 12 Steevithak 2008-06-15 12:06:14 EDT
The new version fixed it for me too. Thanks!
Comment 13 Helge Deller 2008-06-16 12:38:15 EDT
Yep, fixed it for me too. THX.

Note You need to log in before you can comment on or make changes to this bug.