Bug 450705 - yum deadlock
yum deadlock
Status: CLOSED DUPLICATE of bug 444321
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 11:27 EDT by Bill C. Riemers
Modified: 2014-01-21 18:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-31 04:36:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of strace -o yum.log -f yum update (268.46 KB, application/x-bzip2)
2008-06-10 11:30 EDT, Bill C. Riemers
no flags Details

  None (edit)
Description Bill C. Riemers 2008-06-10 11:27:06 EDT
Description of problem:

Yum is deadlocking in "Setting up Update process".

Version-Release number of selected component (if applicable):

yum-metadata-parser-1.1.2-8.fc9.x86_64
yum-packagekit-0.2.2-2.20080529.fc10.x86_64
yum-utils-1.1.13-2.fc9.noarch
yum-3.2.16-2.fc9.noarch

How reproducible:

100% on my system.

Steps to Reproduce:
1. run yum update
2.
3.
  
Actual results:

deadlocks

Expected results:

install updates

Additional info:

I see I am not the only person with this trouble:

http://www.linuxquestions.org/questions/fedora-35/fc9-yum-freezes
Comment 1 Bill C. Riemers 2008-06-10 11:30:03 EDT
Created attachment 308825 [details]
Output of strace -o yum.log -f yum update

I have to use kill -9 to terminate this process.
Comment 2 James Antill 2008-06-10 11:50:53 EDT
 The last part of the strace is:

20191 open("/var/lib/rpm/Packages", O_RDONLY) = 9
20191 fcntl(9, F_SETFD, FD_CLOEXEC)     = 0
20191 fstat(9, {st_mode=S_IFREG|0644, st_size=57294848, ...}) = 0
20191 rt_sigprocmask(SIG_BLOCK, ~[RTMIN RT_1], [], 8) = 0
20191 rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
20191 pread(9,
"\0\0\0\0\1\0\0\0\1\0\0\0\0\0\0\0\0\0\0\0\340\0\227\10\0\2\373\17\366\17\361\17"...,
4096, 4096) = 4096
[...]
20191 pread(9,
"\0\0\0\0\1\0\0\0\271/\0\0\270/\0\0\0\0\0\0\1\0\302\2\0\7doc/\0/"..., 4096,
50040832) = 4096
20191 futex(0x7f4af5d3b2f8, FUTEX_WAIT, 2, NULL) = ? ERESTARTSYS (To be restarted)
Comment 3 James Antill 2008-06-10 11:53:34 EDT
 If you are sure nothing else is using rpm, you can probably fix this by doing:

   rm -f /var/lib/rpm/__db*
Comment 4 seth vidal 2008-06-10 12:03:56 EDT
and then you probably want to run: rpm --rebuilddb
Comment 5 Christopher Beland 2008-10-22 21:53:18 EDT
This looks like it might be the same problem as in bug 444321.
Comment 6 Panu Matilainen 2009-01-31 04:36:42 EST

*** This bug has been marked as a duplicate of bug 444321 ***

Note You need to log in before you can comment on or make changes to this bug.